"Customize with PowerApps" loads App from another SharePoint site

New Contributor


I hope someone may be able to make sense of my title of this post; this is something I have never come across before so if anyone can help that would be fantastic.


Project Introduction

I am currently working on a project where my client requires individual SharePoint sites for each of their customers (companies) to host a quality management system, each site accessible by multiple people within that company. Each QMS site is customised to the end customer depending on their equipment, methods, etc. and making each one was becoming a tedious copy & paste festival.

I managed to make a base site and through LOTS of research was able to create a template site (.wsp file) I could upload and save myself a lot of time only having to make small adjustments and uploading previous QMS related files.


Now, here's the problem:

Three of the lists within each QMS were customised with PowerApps to aid with things like validation, calculation and user-friendliness (I know there are other ways to do this in SP out of the box, but my client liked the aesthetics of the PowerApps).

The issue is now that when I go to a list and choose "Customize with PowerApps", PowerApps loads the version from the original site where the template was made and is the same for all other sites created using this .wsp file.



Being no stranger to computers I did some self-diagnosing to see if I could find the issue.

Firstly I looked in the list settings / form settings to determine if any links where visible. No trace of the app and unable to choose the middle option at all. (yes, the link there does the same)



Secondly I looked in the site settings to see if there is anything that would indicate links; I couldn't find anything, I may be blind.


Thirdly, I looked at the .wsp file in Notepad++ to see if any traces of the apps where transferred over and sure enough, there they were, IDs matched the PowerApps' IDs.


Naturally I looked in the Site Contents, Site Settings and copied the URL but to no avail.


Finally, I used SharePoint Designer 2013 (SP1) to gain access to the site, and found them:


So I did what any normal person would do and deleted the whole folder to see if this would manually clear the cache and allow PowerApps to generate a whole new application. And would you believe it...it didn't work! I tried refreshing the site, clearing my browser's cache, waiting several hours/days but PowerApps still loads the app from the original template site.

I've done a site wide search within SP Designer using the PowerApp IDs but with no luck.


The Plea

If anyone could help, provide a solution or shed some light as to what it is doing; it would be greatly appreciated. I've been at this for days with no luck, and at this point I'm wondering if its not possible.


Thank you kindly,


4 Replies

@JodieFox almost certainly the JSON file behind the customised form is still showing the original site as the embedded app. Be aware that exporting a customised form isn't supported by Microsoft, but you can see a video of how to do it at https://www.bing.com/videos/search?q=power+apps+customised+form+export&docid=608024510142353828&mid=...


Los Gallardos
Intranet, SharePoint and Power Platform Manager (and classic 1967 Morris Traveller driver)

Hi Rob,
Thank you for your speedy reply.
Is there a way of wiping the slate clean so to speak or edit the JSON file as to recreate the customised form from scratch?

I know the exporting of customised forms was not supported and accepted I would have to put in some leg work there :p
Just did not expect it to attempt to transfer something over, I had hoped it would sever any connections to customised forms and allow me to start again if that makes sense?


@JodieFox in the form settings for the List there is a setting to delete the customised form which will reset the form to using the default SharePoint form. You can then re-create the customised form. It's a pain and one day I hope Microsoft will enable customised forms to be created at the same time as the list structure on a new list.


Los Gallardos
Intranet, SharePoint and Power Platform Manager (and classic 1967 Morris Traveller driver)

@RobElliott thank you :)

I followed the instructions in your previous reply.

I have deleted the customised form on the original site which now uses the default SharePoint form.

Unfortunately this hasn't worked as now when "Customize with PowerApps" is selected on the clones, it takes you to the PowerApps create an app screen and doesn't do the usual data import animation. This is the same on all of the cloned sites.


Screenshot 2022-03-14 at 13.49.50.png


Thank you for your help but I think this one is a bust.