Quick Links - Unable to modify URL after a link is created

%3CLINGO-SUB%20id%3D%22lingo-sub-66278%22%20slang%3D%22en-US%22%3EQuick%20Links%20-%20Unable%20to%20modify%20URL%20after%20a%20link%20is%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-66278%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20an%20SPO%26nbsp%3Bsite%20collection%2C%20I've%20created%20a%20modern%20page%2C%20and%20added%20a%20Quick%20Links%20webpart.%20Then%20added%203%20new%20links.%20I%20wanted%20to%20update%20the%20URL%20field%20to%20a%20different%20link%2C%20but%20found%20I%20cannot%20edit%20the%20URL%20field%20within%26nbsp%3Bthe%20Edit%20pane.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20else%20having%20this%20issue%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHaving%20the%20ability%20to%20change%20the%20URL%20is%20quite%20important%2C%20it%20would%20be%20a%20nightmare%20to%20have%20to%20delete%20and%20recreate%20the%20links%2C%20just%20to%20update%20a%20URL.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20everyone%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECindy%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-66278%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-78949%22%20slang%3D%22en-US%22%3ERe%3A%20Quick%20Links%20-%20Unable%20to%20modify%20URL%20after%20a%20link%20is%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-78949%22%20slang%3D%22en-US%22%3EWas%20there%20any%20resolution%20on%20this%3F%20I%20am%20new%20to%20site%20but%20experiencing%20same%20issue.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-66496%22%20slang%3D%22en-US%22%3ERe%3A%20Quick%20Links%20-%20Unable%20to%20modify%20URL%20after%20a%20link%20is%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-66496%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20going%20to%20go%20with%20a%20%22bug%22%2C%20as%20I've%20already%20had%20one%20bug%20fixed%20in%20the%26nbsp%3BQuick%20Links%20webpart%20(clicking%26nbsp%3Blink%20for%26nbsp%3Badding%20image%20froze%20IE11%20browser).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20we%20submit%20this%20as%20a%20potential%20bug%2C%20from%20within%20this%20forum%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20everyone%20for%20the%20feedback%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECindy%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-66449%22%20slang%3D%22en-US%22%3ERe%3A%20Quick%20Links%20-%20Unable%20to%20modify%20URL%20after%20a%20link%20is%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-66449%22%20slang%3D%22en-US%22%3EOr%20a%20lack%20of%20functionality%20in%20the%20WebPart%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-66394%22%20slang%3D%22en-US%22%3ERe%3A%20Quick%20Links%20-%20Unable%20to%20modify%20URL%20after%20a%20link%20is%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-66394%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F43829%22%20target%3D%22_blank%22%3E%40Cynthia%20Walby%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20seems%20to%20be%20a%20bug%20(or%20a%20feature%3F%3F).%20I'm%20getting%20the%20same%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2165336%22%20slang%3D%22en-US%22%3ERe%3A%20Quick%20Links%20-%20Unable%20to%20modify%20URL%20after%20a%20link%20is%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2165336%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F4555%22%20target%3D%22_blank%22%3E%40Matt%20Harrison%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3E2017....%20did%20you%20ever%20find%20a%20way%20to%20edit%20the%20URL%20once%20created%20or%20is%20it%20still%20a%20bug%204%20years%20later%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2165499%22%20slang%3D%22en-US%22%3ERe%3A%20Quick%20Links%20-%20Unable%20to%20modify%20URL%20after%20a%20link%20is%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2165499%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F440102%22%20target%3D%22_blank%22%3E%40El-destructo%3C%2FA%3E%26nbsp%3Bit's%20certainly%20not%20a%20bug%3B%20I%20have%20no%20problem%20changing%20a%20quick%20link's%20url.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERob%3CBR%20%2F%3ELos%20Gallardos%3CBR%20%2F%3E%3CFONT%20size%3D%222%22%20color%3D%22%23006400%22%3EMicrosoft%20Power%20Automate%20Community%20Super%20User%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2165872%22%20slang%3D%22en-US%22%3ERe%3A%20Quick%20Links%20-%20Unable%20to%20modify%20URL%20after%20a%20link%20is%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2165872%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F174092%22%20target%3D%22_blank%22%3E%40RobElliott%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EIs%20this%20in%20SharePoint%20Online%3F%3CBR%20%2F%3EIf%20so%2C%20would%20you%20mind%20pointing%20me%20to%20where%3F%20Note%20this%20is%20the%20QuickLink%20created%20on%20the%20Pages%20tab%20where%20you%20can%20either%20create%20a%20new%20Page%20or%20New%20link.%20The%20details%20don't%20have%20any%20option%20I%20can%20see%20for%20the%20url.%3CBR%20%2F%3ETim%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hello,

 

In an SPO site collection, I've created a modern page, and added a Quick Links webpart. Then added 3 new links. I wanted to update the URL field to a different link, but found I cannot edit the URL field within the Edit pane.

 

Anyone else having this issue?

 

Having the ability to change the URL is quite important, it would be a nightmare to have to delete and recreate the links, just to update a URL.

 

Thanks everyone,

 

Cindy

9 Replies

Hi @Cynthia Walby,

 

This seems to be a bug (or a feature??). I'm getting the same issue.

 

 

Or a lack of functionality in the WebPart :)

I'm going to go with a "bug", as I've already had one bug fixed in the Quick Links webpart (clicking link for adding image froze IE11 browser).

 

Can we submit this as a potential bug, from within this forum?

 

Thanks everyone for the feedback,

 

Cindy 

Was there any resolution on this? I am new to site but experiencing same issue.

@Matt Harrison 

2017.... did you ever find a way to edit the URL once created or is it still a bug 4 years later?

@El-destructo it's certainly not a bug; I have no problem changing a quick link's url.

 

Rob
Los Gallardos
Microsoft Power Automate Community Super User

@RobElliott 

Is this in SharePoint Online?
If so, would you mind pointing me to where? Note this is the QuickLink created on the Pages tab where you can either create a new Page or New link. The details don't have any option I can see for the url.
Tim

Hi Cynthia Walby,
I had same issue so i reach to your post. Now my issue is resolved.
I previously used google chrome for editing sharepoint sites and get those issue.
When I try Microsoft Edge, I do not face such issue.
Now I can properly edit the link update the image of a Quick Link.
Please try using Microsoft Edge.
Regards, Dipu Maharjan
I had the same problem not being able to Edit quick links when using Chrome (the only option showing was Remove).
After reading the above, I used Edge and I the full edit option (Edit, Move, Remove).
Thank you