Promoted links image links?


I had a promoted links area that has been showing images just fine, but this morning we wanted to change the images.  We uploaded the new images into the Site Assets/Images directory (they are 150x150 pixel png files) and copied the links and updated the items in the promoted links list, but now they are displaying as nothing (white page of paper).  

I searched online and did not find much.  What might I be doing wrong?


1-17-2018 10-55-01 AM.png



17 Replies
Don't think they support png images, try convert them to jpg.

Converted them to jpg and unfortunately getting the same.

only other thing i can thing of your using the correct URL and not the scaled version that SharePoint likes to us when copying an image link?
Also does the tiles view in the promited links list show the same? Assuming your using this as a webpart as well, are they both that way or just the webpart?

Both ways as tiles in the list and in a web part.  I am using the "copy link" and editing the items in the list that way.  Should the URL path be something else?  I used copy link in the past and it has worked.  If I need to hard-code a link, what would that link be?

And another strange thing is that if I go back to the stock images we were using, they work just fine.

Open the image by clicking on it and copy the link from the URL bar in your browser vs. using any copy link, cause usually your just copying a thumbnail or something. Or post the link here and lets look at it, you can remove tenant if you wnat.

This is the actual link:


I can see it just fine actually when going right to the link for this one picture.  It is just a strange problem.


I also opened it using Chrome and get the same thing.  I did compatibility view and changed from Edge to IE 8, 9, 10.


Best Response confirmed by Bradley Allison (Contributor)
I see what happened, your falling victim to the new OneDrive/SharePoint file viewer, it opens the image in the view which causes this. If you use Copy Link in the menu, you have to change the option to "With existing access" so it doesn't change permission. Then past that in and just trim the end of the string after .jpg and you should be good.

WOOHOO!!!  I would kiss you right now if I could :p  Thanks and yes, that worked.  Why when I go to "copy" the link would it not work?  I guess now I just need to go in and pare down the other two for right now.

I think I am having your same issue and trying to replicate what you did to alleviate it.  See screen shot of images library where i am trying to copy the link. I don't see the option that @Deleted referenced to view with existing permissions.  And this is what the URL looks like when i copy it using the Copy Link tool


All my images were working prior to the weekend, and then yesterday they all displayed as the white pages.  Help!


That copy link option by selecting People in Org will create a generated secured link, not a direct file link. The People with existing access option "By clicking that "People in _" link, you will see you need to use, so you get a direct link to the file. People must have access to the document / page as well manually set if they don't have it already for the link to work for them as well. 



Christine: I manually deleted the :i:/s/ part of the links to get them to work properly.

Thank you @Bradley Allison @Deleted, a combination of both your suggestions worked, + I had to remove a portion of the end of the URL as well.  What a pain...but glad it is resolved.  Thanks for your help!

Yes! That is it. You saved me a lot of time and effort for such a - seemingly - simple thing. 

Thank you so much. 

Have tried all these options, but still unable to display my sharepoint files from power bi image URL plugin... Have set file to use existing access and trimmed the leading and ending characters... What else could be the problem?