Problem formatting Json with search Choice column

%3CLINGO-SUB%20id%3D%22lingo-sub-2191242%22%20slang%3D%22en-US%22%3EProblem%20formatting%20Json%20with%20search%20Choice%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2191242%22%20slang%3D%22en-US%22%3E%3CP%3EHello%3C%2FP%3E%3CP%3EAll%20my%20json%20formatting%20columns%20work%20fine.%3C%2FP%3E%3CP%3EBut%20I%20have%20one%20%22search%20with%20choice%22%20column%20which%20goes%20on%20error%20(%22Object%20Objet%22)%20as%20following.%20What%20did%20i%20Do%20wrong%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22AEffacer.jpg%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F261445iE85614A0B2510ED9%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22AEffacer.jpg%22%20alt%3D%22AEffacer.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2191242%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Ehelp%20json%20search%20column%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2191561%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20formatting%20Json%20with%20search%20Choice%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2191561%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F666764%22%20target%3D%22_blank%22%3E%40Patgat%3C%2FA%3E%2C%3C%2FP%3E%3CP%3EI've%20had%20the%20same%20behavior%20and%20came%20around%20by%3A%3C%2FP%3E%3COL%3E%3CLI%3ERemove%20my%20formatting%3C%2FLI%3E%3CLI%3EMake%20sur%20that%20the%20column%20in%20question%20is%20shown%3C%2FLI%3E%3CLI%3EFormat%20my%20column%20or%20my%20views%3C%2FLI%3E%3CLI%3EDon't%20forget%20to%20use%20%22youfield.lookupValue%22%3C%2FLI%3E%3C%2FOL%3E%3CP%3EWith%20this%2C%20you'll%20get%20rid%20of%20the%20%5BObject%20object%5D%3C%2FP%3E%3CP%3EAnas%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hello

All my json formatting columns work fine.

But I have one "search with choice" column which goes on error ("Object Objet") as following. What did i Do wrong?

AEffacer.jpg

2 Replies

Hi @Patgat,

I've had the same behavior and came around by:

  1. Remove my formatting
  2. Make sur that the column in question is shown
  3. Format my column or my views
  4. Don't forget to use "youfield.lookupValue"

With this, you'll get rid of the [Object object]

Anas

Thanks a lot, youfield.lookupValue was here the solution.