Previously customized DispForm.aspx and now PowerApps custom form doesn't load in view mode

%3CLINGO-SUB%20id%3D%22lingo-sub-1468706%22%20slang%3D%22en-US%22%3EPreviously%20customized%20DispForm.aspx%20and%20now%20PowerApps%20custom%20form%20doesn't%20load%20in%20view%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1468706%22%20slang%3D%22en-US%22%3E%3CP%3EBefore%20I%20describe%20my%20issue%2C%20first%20I%20want%20to%20confess%20to%20not%20following%20best%20practices%20when%20I%20was%20less-experienced.%20In%20order%20to%20create%20a%20solution%20that%20displayed%20%22related%22%20documents%20(via%20a%20lookup%20column)%20to%20a%20SharePoint%20list%20item%2C%20I%20customized%20DispForm.aspx%20in%20SharePoint%20Designer.%20I%20even%20went%20as%20far%20as%20to%20create%20a%20copy%20of%20DispForm.aspx%20(called%20DispForm2.aspx)%20before%20I%20made%20my%20SPD%20customizations.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFast-forward%204%2B%20years%20and%20now%20the%20same%20list%20needs%20a%20custom%20PowerApps%20form%20because%20PowerApps%20is%20a%20bit%20more%20modern%20looking%20than%20the%20old%20custom%20list%20form.%20So%20far%2C%20everything%20is%20working%20fine%20with%20the%20PowerApps%20custom%20form%20for%20this%20list%2C%20except%20that%20when%20you%20click%20the%20%22Copy%20link%22%20next%20to%20an%20item%20in%20the%20list%2C%20it%20still%20goes%20to%20the%20old%20DispForm2.aspx%20page.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tested%2C%20and%20ViewForm.aspx%20and%20EditForm.aspx%20correctly%20go%20to%20the%20new%20PowerApps%20custom%20form%2C%20but%20just%20DispForm2.aspx%20goes%20to%20the%20wrong%20(old)%20customized%20form.%20Does%20anyone%20know%20if%20there's%20a%20way%20to%20get%20out%20of%20this%20problem%20without%20just%20copying%20the%20list%20data%20and%20recreating%20it%20from%20scratch%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1468706%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2013%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Lists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1469659%22%20slang%3D%22en-US%22%3ERe%3A%20Previously%20customized%20DispForm.aspx%20and%20now%20PowerApps%20custom%20form%20doesn't%20load%20in%20view%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1469659%22%20slang%3D%22en-US%22%3ESwitch%20the%20list%20experience%20over%20to%20modern%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1470843%22%20slang%3D%22en-US%22%3ERe%3A%20Previously%20customized%20DispForm.aspx%20and%20now%20PowerApps%20custom%20form%20doesn't%20load%20in%20view%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1470843%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3BUnfortunately%2C%20the%20list%20is%20in%20Modern%20mode%20and%20still%20shows%20this%20old%20DispForm2.aspx%20page.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Before I describe my issue, first I want to confess to not following best practices when I was less-experienced. In order to create a solution that displayed "related" documents (via a lookup column) to a SharePoint list item, I customized DispForm.aspx in SharePoint Designer. I even went as far as to create a copy of DispForm.aspx (called DispForm2.aspx) before I made my SPD customizations. 

 

Fast-forward 4+ years and now the same list needs a custom PowerApps form because PowerApps is a bit more modern looking than the old custom list form. So far, everything is working fine with the PowerApps custom form for this list, except that when you click the "Copy link" next to an item in the list, it still goes to the old DispForm2.aspx page. 

 

I've tested, and ViewForm.aspx and EditForm.aspx correctly go to the new PowerApps custom form, but just DispForm2.aspx goes to the wrong (old) customized form. Does anyone know if there's a way to get out of this problem without just copying the list data and recreating it from scratch? 

2 Replies
Highlighted
Switch the list experience over to modern?
Highlighted

@Chris Webb Unfortunately, the list is in Modern mode and still shows this old DispForm2.aspx page.