People Web Part not updating

%3CLINGO-SUB%20id%3D%22lingo-sub-1258948%22%20slang%3D%22en-US%22%3EPeople%20Web%20Part%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1258948%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20directory%20page%20(modern%20SP%20page)%20where%20I%20have%20used%20people%20web%20part.%20However%20initially%2C%20we%20just%20had%20profile%20picture%20and%20the%20name.%20Then%20we%20(organisation)%20had%20to%20add%20designation%20for%20each%20user%2C%20which%20we%20did%20through%20admin%20portal.%20However%2C%20it%20did%20not%20reflect%20in%20the%20people%20web%20part%20which%20were%20already%20added%20in%20the%20page.%20But%20If%20I%20now%20add%20a%20new%20people%20web%20part%20in%20the%20same%20page%2C%20it%20takes%20the%20updated%20information.%3CBR%20%2F%3E%3CBR%20%2F%3EIs%20there%20a%20way%20other%20that%20deleting%20complete%20directory%20(people%20web%20part's%20collection)%20and%20adding%20it%20altogether%20newly%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1258948%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Contributor

I have a directory page (modern SP page) where I have used people web part. However initially, we just had profile picture and the name. Then we (organisation) had to add designation for each user, which we did through admin portal. However, it did not reflect in the people web part which were already added in the page. But If I now add a new people web part in the same page, it takes the updated information.

Is there a way other that deleting complete directory (people web part's collection) and adding it altogether newly?

 

0 Replies