Pages library doesn't open pages

%3CLINGO-SUB%20id%3D%22lingo-sub-159916%22%20slang%3D%22en-US%22%3EPages%20library%20doesn't%20open%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-159916%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20an%20issue%20using%26nbsp%3Bthe%20modern%20library%26nbsp%3Bon%20a%20pages%20library.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWhen%20clicking%20a%20page%2C%20the%20library%20itself%20(re)opens%20instead%20of%20the%20page.%20When%20switching%20back%20to%20the%26nbsp%3Bclassic%20view%2C%20clicking%20a%20page%20opens%20the%20page.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20839px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F28711i5EAB45448FE0C206%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22page.jpg%22%20title%3D%22page.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-159916%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-834048%22%20slang%3D%22en-US%22%3ERe%3A%20Pages%20library%20doesn't%20open%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-834048%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F7187%22%20target%3D%22_blank%22%3E%40bart%20vermeersch%3C%2FA%3E%26nbsp%3B%20Did%20you%20figure%20out%20a%20fix%2Fsolution%20for%20this%20issue%3F%20(other%20than%20switching%20back%20to%20classic).%20We%20are%20encountering%20similar%20behavior.%20Thanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-160028%22%20slang%3D%22en-US%22%3ERe%3A%20Pages%20library%20doesn't%20open%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-160028%22%20slang%3D%22en-US%22%3EIs%20this%20problem%20happening%20in%20different%20browsers%20(I%20mean%20IE%2C%20Google%20Chrome%2C%20FireFox)%3F%20From%20your%20screenshot%20it's%20seems%20you%20are%20in%20the%20Pages%20library%20created%20when%20enabling%20the%20publishing%20infrastructure%2C%20right%3F%3C%2FLINGO-BODY%3E
Super Contributor

We have an issue using the modern library on a pages library.

 

When clicking a page, the library itself (re)opens instead of the page. When switching back to the classic view, clicking a page opens the page.

 

page.jpg

 

3 Replies
Is this problem happening in different browsers (I mean IE, Google Chrome, FireFox)? From your screenshot it's seems you are in the Pages library created when enabling the publishing infrastructure, right?

@bart vermeersch  Did you figure out a fix/solution for this issue? (other than switching back to classic). We are encountering similar behavior. Thanks.

In case someone is still wondering why he/she has this issue. Creation of modern pages is supported in the "Site Pages" library only, i.e. /SitePages/ not /Pages/

 

Reference: Create and use modern pages on a SharePoint site - Office Support (microsoft.com)