SOLVED

Page Details crashing SharePoint online

%3CLINGO-SUB%20id%3D%22lingo-sub-742096%22%20slang%3D%22en-US%22%3EPage%20Details%20crashing%20SharePoint%20online%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-742096%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20run%20a%20comm%20site%20for%20our%20Intranet%20and%20when%20a%20news%20article%20is%20posted%2C%20our%20news%20team%20will%20select%20the%20article%2C%20edit%20the%20page%20and%20select%20page%20details%20to%20change%20the%20thumbnail%20of%20the%20article.%20When%20they%20do%20this%20it%20crashes%20SharePoint%20and%20sometimes%20the%20browser.%20We%20have%20tried%20doing%20it%20in%20different%20browsers%20and%20the%20same%20happens.%20This%20issue%20is%20only%20occurring%20on%20this%20specific%20site%2C%20it%20works%20fine%20on%20other%20sites.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20work%20on%20SharePoint%20online%20so%20it%20won't%20be%20an%20issue%20with%20on%20prem%20servers%20etc..%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-742096%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESites%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-742143%22%20slang%3D%22en-US%22%3ERe%3A%20Page%20Details%20crashing%20SharePoint%20online%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-742143%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F263280%22%20target%3D%22_blank%22%3E%40Jamiehopper1%3C%2FA%3E%26nbsp%3BI%20had%20this%20raised%20by%20a%20customer%20today.%20We%20spent%20couple%20of%20hours%20running%20extensive%20testing%20across%20tenants%2C%20site-templates%20and%20browsers.%20This%20issue%20started%20occurring%20in%20Australian%20data-center%20tenants%20from%20last%20week%2C%20it's%20completely%20repeatable%20and%20we've%20tracked%20it%20back%20to%20an%20un-closed%20loop%20in%20.js%20component%20used%20by%20Properties%20component%20in%20details-pane.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20repeatable%20on%20any%20modern%20site%20template%2C%20just%20add%20a%20custom%20metadata%20column%20to%20the%20site%20pages%20library%20and%20then%20edit%20a%20page.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWorkaround%20until%20Microsoft%20fix%20it%2C%20is%20navigate%20to%20the%20Pages%20library%20and%20use%20the%20Quick%20edit%20view%20(with%20required%20metadata%20in%20view)%20or%20select%20item%20and%20click%20on%20edit%20properties%20-%20which%20opens%20the%26nbsp%3B%3CU%3Eclassic%3C%2FU%3E%20properties%20dialogue%20-%20which%20does%20not%20have%20the%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20I%20suggest%20you%20also%20open%20a%20Microsoft%20ticket%20on%20the%20issue%2C%20not%20just%20registering%20on%20the%20forum.%3C%2FP%3E%3CP%3ECheers%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-742373%22%20slang%3D%22en-US%22%3ERe%3A%20Page%20Details%20crashing%20SharePoint%20online%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-742373%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F7527%22%20target%3D%22_blank%22%3E%40Jonathan%20Stuckey%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20response%2C%20this%20helps%20a%20lot.%20I%20will%20be%20sure%20to%20generate%20a%20ticket%20with%20Microsoft%20regarding%20this.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EJust%20another%20quick%20question%20I'm%20hoping%20you%20can%20help%20with%20in%20regards%20to%20your%20workaround.%20When%20I%20have%20navigated%20to%20site%20pages%20and%20selected%20the%20news%20article%20I%20want%20to%20edit%20the%20thumbnail%20of%2C%20I%20selected%20properties%20and%20edit%20item%2C%20but%20I%20cant%20see%20where%20I%20can%20change%20the%20thumbnail%20(below)%2C%20can%20you%20point%20me%20in%20the%20right%20direction%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F122546iB14A8A483CAF1762%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Capture.PNG%22%20title%3D%22Capture.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EJamie.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-743001%22%20slang%3D%22en-US%22%3ERe%3A%20Page%20Details%20crashing%20SharePoint%20online%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-743001%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F263280%22%20target%3D%22_blank%22%3E%40Jamiehopper1%3C%2FA%3E%26nbsp%3BHaving%20the%20same%20issue%20here%20as%20well.%20I'm%20also%20seeing%20that%20the%20search%20crawler%20isn't%20picking%20up%20additional%20properties%20on%20a%20page.%20Anyone%20else%20experience%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-743035%22%20slang%3D%22en-US%22%3ERe%3A%20Page%20Details%20crashing%20SharePoint%20online%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-743035%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F260499%22%20target%3D%22_blank%22%3E%40dmowry%3C%2FA%3E%26nbsp%3BJust%20checked%20my%20pages%20a%20few%20moments%20ago%20and%20it%20appears%20Page%20Details%20is%20loading%20now.%20I%20had%20reported%20this%20to%20MS%20support%20earlier%20in%20the%20day%20and%20it%20may%20have%20been%20looked%20at%20and%20resolved.%20Also%20fixed%20my%20issue%20with%20search%20crawler%20not%20picking%20up%20values%20in%20page%20details.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

We run a comm site for our Intranet and when a news article is posted, our news team will select the article, edit the page and select page details to change the thumbnail of the article. When they do this it crashes SharePoint and sometimes the browser. We have tried doing it in different browsers and the same happens. This issue is only occurring on this specific site, it works fine on other sites.

 

We work on SharePoint online so it won't be an issue with on prem servers etc..

 

Any ideas?

4 Replies
Highlighted
Best Response confirmed by Jamiehopper1 (Occasional Contributor)
Solution

@Jamiehopper1 I had this raised by a customer today. We spent couple of hours running extensive testing across tenants, site-templates and browsers. This issue started occurring in Australian data-center tenants from last week, it's completely repeatable and we've tracked it back to an un-closed loop in .js component used by Properties component in details-pane.

 

This is repeatable on any modern site template, just add a custom metadata column to the site pages library and then edit a page. 

 

Workaround until Microsoft fix it, is navigate to the Pages library and use the Quick edit view (with required metadata in view) or select item and click on edit properties - which opens the classic properties dialogue - which does not have the issue.

 

Can I suggest you also open a Microsoft ticket on the issue, not just registering on the forum.

Cheers

Highlighted

Hi @Bongo_ho ,

 

Thanks for your response, this helps a lot. I will be sure to generate a ticket with Microsoft regarding this.

 

Just another quick question I'm hoping you can help with in regards to your workaround. When I have navigated to site pages and selected the news article I want to edit the thumbnail of, I selected properties and edit item, but I cant see where I can change the thumbnail (below), can you point me in the right direction?

Capture.PNG

 

Thanks,

Jamie.

Highlighted

@Jamiehopper1 Having the same issue here as well. I'm also seeing that the search crawler isn't picking up additional properties on a page. Anyone else experience this issue?

Highlighted

@dmowry Just checked my pages a few moments ago and it appears Page Details is loading now. I had reported this to MS support earlier in the day and it may have been looked at and resolved. Also fixed my issue with search crawler not picking up values in page details.