Organization assets library

Contributor

I can create an organizational asset library using power shell without issue if my -Orgtype is the default "ImageDocumentLibrary,".  If I try to create a Office Template library, with the below command it does run successfully with no errors.  But the library does not seem to receive the additional attributes it needs to become a Template library, as I can not the see the template library in any picker nor do I see it in any of the office products(word, Excel, Powerpoint ect). 

 

Add-SPOOrgAssetsLibrary -LibraryURL https://contoso.sharepoint.com/sites/branding/Assets -ThumbnailURL https://contoso.sharepoint.com/sites/branding/Assets/contosologo.jpg -OrgAssetType OfficeTemplateLibrary

 

Am I missing a step to get this working?

26 Replies

@itsbrad 

Hello,

Please use Remove-SPOOrgAssetsLibrary to remove all and add the https://contoso.sharepoint.com/sites/branding/Assets/contosologo.jpg -OrgAssetType OfficeTemplateLibrary first

Unfortunately this did not work for me

@itsbrad 

You have to use this:

Add-SPOOrgAssetsLibrary -LibraryURL https://YourDomain.sharepoint.com/sites/branding/Office -OrgAssetType OfficeTemplateLibrary

That's what I used, but it didn't work unfortunately

@itsbrad 

No check the script that you mentioned in the original post

Here is the difference:

https://contoso.sharepoint.com/sites/branding/Assets/contosologo.jpg -OrgAssetType OfficeTemplateLibrary

https://contoso.sharepoint.com/sites/branding/Office -OrgAssetType OfficeTemplateLibrary

 

Thanks for your insight @Alireza Rahimifarid but you are actually reading the original post incorrectly.  The full command I posted is:

 

"Add-SPOOrgAssetsLibrary -LibraryURL https://contoso.sharepoint.com/sites/branding/Assets -ThumbnailURL https://contoso.sharepoint.com/sites/branding/Assets/contosologo.jpg -OrgAssetType OfficeTemplateLibrary"

 

The above is all one long command it just doesn't fit in the post.  If I even eliminate the thumbnail portion and only run:

 

"Add-SPOOrgAssetsLibrary -LibraryURL https://contoso.sharepoint.com/sites/branding/Assets -OrgAssetType OfficeTemplateLibrary"

 

I get the  same result, a successful command but the library does not show up anywhere as a Template Library.

 

I have a support ticket open with Microsoft, they confirmed they were able to duplicate the issue and are testing.

 

@itsbrad 

i have the same issue. Picture went fine, office template no

@Vertebre85 @itsbrad 

please note office template will be showing in Office product not SharePoint

 

office templates.JPG

Thanks its not showing in Office either, is there a configuration that needs to be done to Office, or is there a way to check if office is configured properly?

@Alireza Rahimifarid 

Then the documentation is incorrect

Vertebre85_0-1589018965971.png

https://docs.microsoft.com/en-us/sharepoint/organization-assets-library

Finally I manage to make it work, but only with office 365 pro plus

It doesn't work on Office 2016 ( maybe that the reason why it doesn't work for @itsbrad )

We are using E3 or E5 licences with the Semi annual channel of the Latest Office 365 Pro plus. But it’s not working.

I am going to test with a more frequent office 365 update channel.

@Vertebre85 

I couldn't find they mention Office 2016 in the document, but We have E5- Semi annual update and it worked right away. Let's wait for the result of Support ticket.

 

@Alireza Rahimifarid  I am seeing the same thing - I can execute the command, it creates the library when I execute the command again - it says it already exists but, It isn't showing up in my microsoft applications, either online or installed on the desktop.  Did you find any solutions? 

Is it working via word online?

On my tenant not yet in Word online, only in PowerPoint online so it may come in word

Vertebre85_0-1606400653175.png

My templates stored in the organization asset library are listed in the folder "templates"

I kind of gave up on this for a while as it dropped in priority and MS support was spinning their wheels. Recently I checked and the Organization assets library is now showing up correctly on word, excel and PowerPoint. So perhaps its one of those features that just takes time to full rollout to tenants or maybe support did something but never advised me.

Anyway for now its working correctly.

@itsbrad 

Hi,

I have found that it really can take some time for the templates to show up.

 

For me the template folder shows in all the desktop versions of Office (Word, Excel, PP) and in PowerPoint Online, but not in Excel Online or Word Online. 

 

What can cause this behaviour?

 

Thanks,

Peeter

@pemo_ 

 

We're seeing the same, with the templates showing in Word, Excel, PowePoint applications, but only in the PowerPoint web app, not Word or Excel web app. 

 

Time to raise a ticket with MS. 

 

Thanks,

Carl

@ can just confirm the same issue in our environment still one month later.

Word Excel and PPT locally installed apps are showing the Templates. But Word/Excel online don't. Just in PPT I see an additional Folder with the PPT Templates from the Asset Library

Thanks and kind regards
Rudolf