Open in client application when sharing link

Copper Contributor

I know it is possible to set files to open in client applications when opening up a file from a SharePoint library, but is it possible to set that as default behavior when opening a file from a shared link?  I have set the site collection default to open in client application and library setting to open in client application but when I send a co worker a shareable link out of sharepoint it will only open in the web version.

35 Replies
best response confirmed by Nathaniel Ekdahl (Copper Contributor)

You can't set Shared Links to open directly in Client Application. You will have to manually create a link in below format and share it to open in client application.


The following will open in the client directly:

This link will prompt user to open in client application  





Got it, thank you very much for the assistance.

@Deleted - How do you create that custom link? Where do you do this at in SharePoint?

Personally I think every possible way to open a document in SharePoint (or other apps like Teams etc) should be default to open in client application - The user experience in the online version is simply too poor to even consider in most cases. I cannot understand why MS has chosen to force users into a bad experience.


However a relatively simple workaround for this is to (from within the Office app) go to "file" and then click "copy path" button. Paste the copied link into your email, Teams chat or wherever you want to share it and then remove the "?web=1" part at the end. 


How do you create the link which prompts the user to open in client application?

I tried copying the start of your example but it doesn't work.


Many Thanks

Well, if I (from within an office app) go to "file" and then click "copy path" (circled in blue in the attached pic). Then I can paste this link into e.g. Outlook and remove the trailing "?web=1" then, at least for me, it will open in the client app.


open in client.JPG

On my system, it downloads the file if I remove the ?web=1. My file>Info tab doesn't have the options below the file name, I have to click on it to get them, so maybe it's a difference in the versions?


However, I have managed to get the prefix of ms-word:ofe|u| working. 

Thank you but this seems to only give you the option to open the files in MS Word as a read-only version instead of working with the live version saved on the site.
Ok that's interesting. For us this trick works well. It do opens as read-only but if we click "edit document" on the yellow ribbon, make changes and save. those changes will be saved in the original document on SharePoint.



Thanks for the tip, yet I try and use it, upon clicking on the link, I've got the message "This action couldn't be performed because Office doesn't recognize the command it was given"... :( 


I double-check the syntax and it seems correct. Any idea what is going wrong, please?





Well, I actually found the issue myself. I was giving the path and name of a ".ppt" document instead of a ".doc" document, after the command... I replaced with a ".doc" and it works. Great!


This brings me to share the fact that the hint also works with PowerPoint, as long as you use the command "ms-powerpoint:ofe|u|" before the file name...


Thanks a lot! 

This does NOT appear to work in the Quick Links webpart unfortunately in SharePoint Modern. 

@Erik Wettergren I totally agree. Poor experience here. It creates a lot of friction... 

Just posted on this same issue at "I just shared an excel document stored on SharePoint link in Teams chat and it downloads the file.  I added the "?Web=1" after having to go into edit mode and create a link and that works to open in the browser.  WHY DOES THE LINK DOWNLOAD AND NOT OPEN IN THE NATIVE APP?   This is really getting frustrating.  I tried the "ms-excel:ofe|u|" prefix and the link creator said it was not a valid link and would not let me even try it.  Any help appreciated.  I agree with another poster that having to add extensions and prefixes cannot be sustainable, either.  Behavior of the link should not be based on settings in individual systems either for collaboration."

I have been trying to use this format URL with URI prefix on text in a text field in a sharepoint list, and the link always fails.  Sharepoint seems to remove the entire url.  Am i doing something wrong?


This may be confusing, but let's put it this way, in a multiline rich text field i put the link

<a href="ms-excel:nft|u|">Form Template</a>


and sharepoint will not allow that link to work.  It usually trims it down to <a>Form Template</a>.


any ideas?

i did just find that edge deals with this issue much better than chrome. now i have to decide if it's worth abandoning chrome for this. ugh!
The only workaround I have managed is to use ms-word:ofe|u| and then create a tiny URL. Not great but it works and you get a URL that SharePoint and teams will accept as a link.



Can you explain how you used ms-word:ofe|u| in a "Link: with in SharePoint? 


I just get the "This link type is not supported."

If you try and use it within SharePoint then you will get that error as it does not recognise it as a hyperlink but, if you go to tinyurl or something similar you can then put it in there and output an actual http hyperlink that SharePoint will recognise