Not able to paste bulk rows into SharePoint list online from Excel

Copper Contributor

Hi guys,


Looks like some changes were made in MSFT end and the way to work with SharePoint lists has changed. I was able to copy up to 100 rows from Excel and paste them into SharePoint lists following this steps:

 1- clicking the "Edit in grid view" button,

 2- Scrolling to the end of the 100 first rows in the list

 3- Click the + icon and select the blank last row

 4- Paste the 100 rows from Excel


It was easy-peasy, now, I have a list with over 25k rows, and we update this about once a week, this was the fastest way to do this, and now, even when I take a lot of time scrolling down to the last row to find the '+' icon, it wouldn't let me paste more than 1 row from Excel, it only allows to paste 1 single row at a time. 

So, do you guys know if this is a glitch or is this new way things will work for SharePoint lists online? 


Thank you for your insights!



14 Replies

Hi @YavapaiR 

I don't have any details about if there is an issue currently but I believe you can save some time on the "even when I take a lot of time scrolling down to the last row to find the '+' icon" step by creating an empty view to insert the data.



  • Create a new view. Ex: "Bulk Insert"
  • Select "Edit in grid view" and save the view


  • Go to list settings > edit the new view
  • Add a filter like "ID = 0" (a condition that will never be true)



Now you have a view that you can quickly select to add data in quick edit mode. Everytime you switch to the view, it will be empty and ready to use.




@luis-ribeiro ,


Thanks for the suggested approach, good one! However, it doesn't solve the fact that we can't paste more than one row at a time from Excel to the SP list, whereas we were able to paste 100 at a time, I would like to know if this is happening only on my end or if it's something rolled out by MSFT ¯\_(ツ)_/¯

I am having this same problem. Was able to paste many rows just last week, now I am unable to bulk paste. MS team constantly removing basic features like copy and paste is actually embarrassing and I hope they have a quick fix for this.
I ended up creating a flow that will upload the rows for me, with the limitation of getting error when I try to upload 100+ rows.
I found that I could do this but it was fiddly. The first paste would put everything into the first column cell delimited with spaces. So I deleted and moved the cursor to the next column cell and then back to the first and was able to paste all rows.


If you use the classic experience you are able to past multiple rows.

Nope, I already tried this and it didn't work.

Just hit this problem, if it's a relatively small amount of rows, in Edit In Grid View mode, you need to click "+ Add New", then click the bar next to the radio button on the row (which highlights the whole row), then you can paste multiple entries into the list (thanks to my colleague Kevin for that!)

@RobR69 tell Kevin thank you! This worked a treat has has saved me a substantial amount of time.

Thanks - it really helped! From 2.5 hours to 2 minutes

This is how I used to upload new batch of rows, not working anymore until today. Continue using a flow to upload new rows. Not sure it's because the amount of rows we currently have, that is over 25k.



This worked perfectly! Thank you!  I was going nuts with the bugginess 


Could you be clearer in explaining the steps on how you got around the problem?