News web part site name not linking to correct site URL

Brass Contributor

Just wondering if anyone else has seen this problem.  We are using the news web part in each of our site in a site collection.  Each site is aggregating the news posted from the other sites.  It's displaying the news from each site fine, but the site name that appears above the news title is a clickable link that does not go to the source site where the news originated from.  For example, name is a hub site.  We created a number of other child sites under this site, such as  When viewing the news web part from either the hub site or the BusinessServices site, the link to "Business Services" always go to  This happens for all the other sites as well.  If we click on the image or the news title, then it goes to the correct site and news page.  It seems the site name should allow the user to click to the site where the news originated from.  I don't see anything in the web part that would affect this behavior, and am considering opening a support ticket for this as it is confusing some of our users.

7 Replies

Yes, I see the same problem with News app on our sites in SPO. It is very confusing for end users. 

I had to open a ticket with Microsoft support.  It's been escalated to the Product group but still no word yet as to a fix (it has been a month).  No clear details on when the fix will be implemented, although I do get frequent updates that it's under discussion.  I'll update when I get a resolution.

I've been told by Microsoft that this is now an internal bug for the Product Engineering team and the estimated rollout for the fix should be by the new year.

Thank you for the update, Thao. Much appreciated.

@Thao Pham-Aaltonen 

This is really wierd, we are starting to see the same error now, well over three years later!

I made a Microsoft support call on this issue. Can anybody recall what resolution they provided?

@JesperGSimonsen We are experiencing this same issue as well.  It just recently happened from what I can tell.  

@Thao Pham-Aaltonen 

I am seeing this problem now too. It worked for several weeks, and suddenly the link (which is in the label) does not work anymore. What's more.. it's intermitted, between sessions and between users. So most of the users most of the time.