News web part - 'See all' not honoring filters

%3CLINGO-SUB%20id%3D%22lingo-sub-3123821%22%20slang%3D%22en-US%22%3ENews%20web%20part%20-%20'See%20all'%20not%20honoring%20filters%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3123821%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20just%20added%20a%20news%20web%20part%20to%20a%20site%20collection%20that%20is%20a%20part%20of%20my%20organisation's%20intranet%20(a%20'topic'%20site).%26nbsp%3B%20Our%20corporate%20news%20articles%20get%20published%20in%20a%20separate%20site%20collection%20and%20the%20pages%20are%20tagged%20with%20our%20topics.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20source%20for%20the%20news%20web%20part%26nbsp%3B%20that%20I%20have%20added%20to%20is%20the%20appropriate%20site%20collection%20(i.e.%20not%20'this%20site')%20and%20I%20have%20added%20a%20filter%20to%20only%20display%20pages%20with%20that%20have%20been%20tagged%20with%20the%20appropriate%20topic.%3C%2FP%3E%3CP%3EThe%20correct%20pages%20are%20turning%20up%20in%20the%20web%20part%20on%20the%20page.%26nbsp%3B%20However%2C%20when%20I%20click%20through%20on%20the%20'see%20all'%20option%2C%20the%20generated%20'all%20posts'%20page%20is%20just%20showing%20all%20our%20news%20pages%20rather%20than%20only%20pages%20that%20match%20the%20filter%20that's%20been%20added%20in%20the%20web%20part.%3C%2FP%3E%3CP%3EI%20have%20done%20this%20elsewhere%20in%20my%20tenant%20and%20the%20'See%20all'%20list%20usually%20honours%20the%20filters%20that%20have%20been%20set%20up%20in%20the%20web%20part.%3C%2FP%3E%3CP%3ECan%20anyone%20else%20in%20the%20community%20let%20me%20know%20if%20they%20are%20experiencing%20same%20issue%20before%20I%20raise%20an%20issue%20with%20Microsoft.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3123821%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3123852%22%20slang%3D%22en-US%22%3ERe%3A%20News%20web%20part%20-%20'See%20all'%20not%20honoring%20filters%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3123852%22%20slang%3D%22en-US%22%3EI%20think%20this%20is%20expected%20behaviour%20for%20that%20web%20part.%20I%20have%20created%20a%20custom%20%22See%20All%22%20link%20pointing%20to%20a%20page%20that%20has%20the%20same%20webpart%20with%20the%20filter%20but%20just%20showing%20more%20results.%3CBR%20%2F%3E%3CBR%20%2F%3EWhen%20you%20see%20a%20%22See%20All%22%20on%20a%20list%20or%20library%20web%20part%20it%20is%20generally%20utilising%20a%20saved%20view%20which%20it%20uses%20for%20the%20See%20All%20page%2C%20where%20as%20the%20news%20filter%20is%20applied%20on%20the%20page%20web%20part%20so%20the%20See%20All%20page%20doesn't%20have%20the%20same%20filter%20applied.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3123915%22%20slang%3D%22en-US%22%3ERe%3A%20News%20web%20part%20-%20'See%20all'%20not%20honoring%20filters%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3123915%22%20slang%3D%22en-US%22%3EHi%20Warwick%3CBR%20%2F%3EThanks%20for%20your%20reply%2C%20but%20I'm%20not%20sure%20this%20is%20right.%20The%20'See%20all'%20uses%20as%20its%20title%20the%20same%20heading%20as%20the%20web%20part.%20By%20extension%2C%20it%20should%20be%20showing%20(at%20very%20least)%20the%20same%20news%20pages%20at%20the%20top%20of%20the%20list%20as%20appear%20on%20the%20page%20on%20which%20the%20web%20part%20has%20been%20placed%2C%20which%20it%20isn't.%3CBR%20%2F%3EAs%20I've%20mentioned%2C%20I%20have%20other%20instances%20where%20the%20See%20all%20link%20is%20displaying%20same%20results%20as%20the%20filters.%20I%20have%20an%20idea%20it%20will%20be%20related%20to%20the%20fact%20that%20I%20am%20using%20a%20'RefinableString'%20value%20that%20I've%20set%20up%20in%20the%20Search%20Schema%20(mapped%20crawled%20properties)%20in%20the%20filter.%3CBR%20%2F%3EThe%20examples%20where%20things%20are%20working%20are%20using%20an%20out%20of%20box%20managed%20property%20(author%20byline)%20rather%20than%20my%20custom%20property.%3CBR%20%2F%3EI'll%20do%20a%20bit%20more%20research%20around%20limitations%20when%20using%20mapped%20crawled%20properties%20in%20the%20News%20web%20part.%3CBR%20%2F%3EI'd%20appreciate%20advice%20from%20anyone%20who's%20got%20lots%20of%20experienced%20with%20managing%20Search%20schema%20in%20the%20multi-site%20collection%20world%20of%20SharePoint%20Online!%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E
Contributor

I've just added a news web part to a site collection that is a part of my organisation's intranet (a 'topic' site).  Our corporate news articles get published in a separate site collection and the pages are tagged with our topics.  

The source for the news web part  that I have added to is the appropriate site collection (i.e. not 'this site') and I have added a filter to only display pages with that have been tagged with the appropriate topic.

The correct pages are turning up in the web part on the page.  However, when I click through on the 'see all' option, the generated 'all posts' page is just showing all our news pages rather than only pages that match the filter that's been added in the web part.

I have done this elsewhere in my tenant and the 'See all' list usually honours the filters that have been set up in the web part.

Can anyone else in the community let me know if they are experiencing same issue before I raise an issue with Microsoft.

 

Thanks

5 Replies
I think this is expected behaviour for that web part. I have created a custom "See All" link pointing to a page that has the same webpart with the filter but just showing more results.

When you see a "See All" on a list or library web part it is generally utilising a saved view which it uses for the See All page, where as the news filter is applied on the page web part so the See All page doesn't have the same filter applied.
Hi Warwick
Thanks for your reply, but I'm not sure this is right. The 'See all' uses as its title the same heading as the web part. By extension, it should be showing (at very least) the same news pages at the top of the list as appear on the page on which the web part has been placed, which it isn't.
As I've mentioned, I have other instances where the See all link is displaying same results as the filters. I have an idea it will be related to the fact that I am using a 'RefinableString' value that I've set up in the Search Schema (mapped crawled properties) in the filter.
The examples where things are working are using an out of box managed property (author byline) rather than my custom property.
I'll do a bit more research around limitations when using mapped crawled properties in the News web part.
I'd appreciate advice from anyone who's got lots of experienced with managing Search schema in the multi-site collection world of SharePoint Online!

makes sense, I would go to Microsoft support then, they will either come back with unsupported or a "we'll add it to out list of future improvements list"
Hi Jenny,
I am having the same issue. It filters properly when using page properties for a single site, but when filtering by a managed property from multiple sites it has been rolling up all news posts (unwanted). This was not the case a month ago, so hopefully a fix could come soon.

Hi @GeraldMarquez 

Thanks for confirming someone else has observed this issue.  The timing you refer to is also consistent with my experience.

I've since discovered something even more puzzling.  Although I am not seeing the pages that match the filter my end users are.  As my user account has SharePoint Admin role + is in site collection admin, this seems particularly odd.

I've decided that as the issue isn't affecting my end users, it's probably going to be too hard to get Microsoft to troubleshoot this so haven't bothered raising as issue.