News Web Part "Add > News post" not working

Deleted
Not applicable

We are experiencing an issue where the "+ Add" then "News Post" doesn't work for any of our users.  Using "+ Add" then "News Link" does still work.  Anyone else experience an issue like this?

11 Replies

We are also having this issue today.  We can add the first news post using the larager button on the web part but then trying to use the New > News Post button isn't doing anything.  Did you get anywhere with this issue?

No, I am still having this issue.  I was hoping it would fix itself after a few days, but it did not.

Out of curiosity what browser are you using?  I was using Edge and experienced the problem but when I tested in Chrome yesterday it worked ok.

 

At the moment I'm finding that quite a lot of the modern UI stuff has issues in Edge from time to time, but always seems to work fine in Chrome!

Can you please share what version of Edge are you using and any more details (is there an error message or a network failure/trace?)

Hi Anton

 

I'm have the following version information:

 

Microsoft Edge 41.16299.665.0

Microsoft EdgeHTML 16.16299

 

With developer tools open I get the following error in the console after clicking the Add News Post link:

Capture.PNG

We are also having the same issue with Edge browser - "+ Add" / "News Post" option in News app doesn't work. It works in Chrome and Firefox browsers. I am using Edge 40.15063.674.0 (and Windows 10). there is no error message on my screen when I click to add News Post in News app.

 

this should now be fixed. Can you verify ?

That's great, just tried it now and all working :)
We ran into a similar issue where the News post link wasn't working for our top-level hub site. We've given contribute access directly to the site using the SharePoint Visitors group to allow all users to create news posts. To prevent all users from editing the home page, we changed the access for that specific page in the Site Pages library to read-only for the Visitors group. Site Owners have full access the the site, including the home page, and could use the link fine. It looks like the user needs to have the ability to edit whichever page the News web part is presented on to use the "News post" link successfully. We thought we had this working with read-only access to the page as of about 10/7/2021. But as of 10/15/2021 the permissions appear to be preventing the use of that link without page edit permissions.

Our workaround for now is to:

- Create a separate page with instructions on creating news posts
- Add a link to the instruction page that links to the same page you get when clicking the "See All" link from a News web part. It's a system generated page that users with site contribute permissions can use the Add > News post link on, but they can't edit the actual page. The link will be something like "..._layouts/15/news.aspx?title=.....
- Add a button "Add News Post" and include it on the page where the News web part is posted. For us, this was a hub site home page marked read-only for our site Visitors group to prevent them from changing it.
- Deselect the "Show title and commands" option for the News web part to hide the Add button to avoid confusion as it won't work.
We are currently investigating this behavior
Any news on this? We have the same issue". Add News post" = doesn't show up in the listed news. "Add News link" works.