Home

News filter on page properties not working for news link repost page

%3CLINGO-SUB%20id%3D%22lingo-sub-676194%22%20slang%3D%22en-US%22%3ENews%20filter%20on%20page%20properties%20not%20working%20for%20news%20link%20repost%20page%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-676194%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20category%20field%20added%20to%20the%20site%20pages%20library%20with%20a%20multi-select%20choice%20field.%20On%20a%20news%20page%2C%20I%20am%20displaying%20the%20news%20in%20several%20web%20parts%2C%20filtered%20by%20that%20category.%20It%20works%20great...%20or%20so%20I%20thought.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20turns%20out%20that%20if%20it's%20a%20%22news%20link%22%20or%20%22repost%20page%22%20then%20it%20does%20not%20display%20for%20any%20page%20properties%20filter.%20But%20here's%20the%20kicker%20-%20it%20works%20for%20people%20with%20elevated%20rights...%20we%20see%20the%20repost%20page%20in%20the%20filtered%20display....%20and%20people%20with%20read%20rights%20do%20not.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20only%20true%20for%20the%20page%20properties%20filter.%20All%20other%20filters%20(like%20title%2C%20created%20by%2C%20etc)%20work%20as%20expected.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20behavior%20is%20the%20same%20for%20the%20highlighted%20content%20and%20the%20news%20web%20part.%20HELP!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-676194%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1169606%22%20slang%3D%22en-US%22%3ERe%3A%20News%20filter%20on%20page%20properties%20not%20working%20for%20news%20link%20repost%20page%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1169606%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F160180%22%20target%3D%22_blank%22%3E%40Lori%20Wilson%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20quite%20old%20but%20did%20you%20manage%20to%20solve%20your%20issue%3F%20My%20problem%20is%20a%20bit%20similar%2C%20although%20I%20am%20site%20collection%20admin%2C%20the%20Highlight%20web%20part%20does%20not%20return%20any%20%22repost%20page%22%20at%20all%2C%20even%20if%20I%20select%20%22All%22%20in%20Type.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3ERoch_%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1183103%22%20slang%3D%22en-US%22%3ERe%3A%20News%20filter%20on%20page%20properties%20not%20working%20for%20news%20link%20repost%20page%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1183103%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F59316%22%20target%3D%22_blank%22%3E%40Roger%20Roch%20Vissio%3C%2FA%3E%26nbsp%3Byes%20we%20did.%20The%20relevant%20data%20point%20was%20that%20people%20with%20elevated%20access%20could%20see%20it.%20Here's%20what%20was%20happening%3A%3C%2FP%3E%3CP%3EAuthor%20creates%20news%20link%20-%20pastes%20in%20link%2C%20publishes%20-%20it%20works%3C%2FP%3E%3CP%3EAuthor%20realizes%20they%20forgot%20to%20set%20the%20category%20field%20for%20where%20it%20should%20show%20up%3C%2FP%3E%3CP%3EAuthor%20goes%20to%20the%20news%20link%20page%20and%20clicks%20to%20edit%20the%20properties%20(without%20going%20into%20edit%20mode)%3C%2FP%3E%3CP%3EThis%20leaves%20it%20in%20a%20checked%20out%20state%20-%20and%20makes%20it%20not%20visible%20to%20viewers%3C%2FP%3E%3CP%3ESolution%3A%20training%20authors%20to%20always%20edit%20and%20republish%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIDK%20if%20that%20helps%20you%20but%20we%20are%20also%20having%20a%20different%20news%20link%2Frepost%20page%20issue%20that%20we%20have%20a%20support%20ticket%20in%20to%20microsoft%20for.%20Something%20in%20that%20feature%20changes%20a%20few%20weeks%20ago%20and%20it's%20impacting%20our%20use%20of%20it%20in%20many%20places.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Lori Wilson
New Contributor

I have a category field added to the site pages library with a multi-select choice field. On a news page, I am displaying the news in several web parts, filtered by that category. It works great... or so I thought.

 

It turns out that if it's a "news link" or "repost page" then it does not display for any page properties filter. But here's the kicker - it works for people with elevated rights... we see the repost page in the filtered display.... and people with read rights do not.

 

This is only true for the page properties filter. All other filters (like title, created by, etc) work as expected.

 

The behavior is the same for the highlighted content and the news web part. HELP!

2 Replies
Highlighted

Hi @Lori Wilson,

 

This is quite old but did you manage to solve your issue? My problem is a bit similar, although I am site collection admin, the Highlight web part does not return any "repost page" at all, even if I select "All" in Type.

 

Regards,

Roch_

Highlighted

@Roger Roch Vissio yes we did. The relevant data point was that people with elevated access could see it. Here's what was happening:

Author creates news link - pastes in link, publishes - it works

Author realizes they forgot to set the category field for where it should show up

Author goes to the news link page and clicks to edit the properties (without going into edit mode)

This leaves it in a checked out state - and makes it not visible to viewers

Solution: training authors to always edit and republish

 

IDK if that helps you but we are also having a different news link/repost page issue that we have a support ticket in to microsoft for. Something in that feature changes a few weeks ago and it's impacting our use of it in many places.

Related Conversations