SOLVED
Home

Multiple news web parts with a filter on a homepage

%3CLINGO-SUB%20id%3D%22lingo-sub-236784%22%20slang%3D%22en-US%22%3EMultiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-236784%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3CBR%20%2F%3E%3CBR%20%2F%3ECurrently%20we%20are%20in%20the%20middle%20of%20creating%20a%20new%20intranet.%20One%20of%20the%20functionalities%20is%20the%20ability%20to%20show%20news%20in%203%20columns%20depending%20on%20the%20type%20of%20news.%20Therefor%20we%20created%20a%20site%20column%20'News%20category'%20with%20the%20following%20choices%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CUL%3E%3CLI%3EBreaking%3C%2FLI%3E%3CLI%3EDaily%3C%2FLI%3E%3CLI%3EOther%3C%2FLI%3E%3C%2FUL%3E%3CP%3EThis%20is%20working%20perfectly%20and%20we%20can%20tag%20the%20news%20pages%20using%20the%20new%20feature%20Page%20Details.%20Now%20we%20want%20to%20show%20the%20correct%20news%20in%20the%20correct%20column%20on%20the%20homepage.%20So%20we%20add%20the%20news%20web%20part%20in%203%20different%20column%20and%20select%20the%20following%20settings%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3ESource%3A%20this%20site%3C%2FLI%3E%3CLI%3ELayout%3A%20list%3C%2FLI%3E%3CLI%3EAmount%20of%20news%3A%204%3C%2FLI%3E%3CLI%3EFilter%3CUL%3E%3CLI%3EPage%20properties%3C%2FLI%3E%3CLI%3ENews%20category%20is%20equal%20too%20Breaking%20(or%20Daily%20or%20Other%2C%20depending%20on%20which%20news%20web%20part%20we%20are%20configuring)%3C%2FLI%3E%3C%2FUL%3E%3C%2FLI%3E%3C%2FUL%3E%3CP%3EThis%20seems%20to%20work%20perfectly%20after%20configuring%20the%20web%20parts%20and%20publishing%20the%20page.%20The%20problem%20exists%20when%20I%20refresh%20the%20page%20or%20somebody%20else%20visits%20the%20page.%20The%20filters%20are%20totally%20mixed%20up.%20Some%20news%20that%20is%20tagged%20Breaking%20is%20now%20showing%20in%20the%20Daily%20news%20web%20part.%20Or%20some%20news%20page%20is%20being%20shown%20in%20Breaking%2C%20Daily%20and%20Other.%26nbsp%3B%3CBR%20%2F%3EWhen%20I%20check%20each%20web%20part%20setting%20the%20filters%20are%20still%20correctly%20configurated%20but%20it%20seems%20that%20SharePoint%20forget%20to%20apply%20the%20filter%20after%20publishing%E2%80%A6%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20also%20tried%20the%20same%20functionality%20using%20the%20Highlighted%20Content%20web%20part%20and%20there%20it%20works%20perfectly.%20But%20then%20my%20users%20have%20to%20deal%20with%20the%20fact%20that%20on%20each%20picture%20the%20SharePoint%20page%20icon%20is%20being%20shown.%20We%20prefer%20to%20use%20the%20news%20web%20part%20for%20the%20cleaner%20look.%3CBR%20%2F%3E%3CBR%20%2F%3ESome%20other%20details%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CUL%3E%3CLI%3EThe%20site%20is%20a%20communication%20site%3C%2FLI%3E%3CLI%3EThe%20site%20is%20promoted%20to%20a%20Hub%20site%3C%2FLI%3E%3CLI%3E3%20Team%20sites%20are%20currently%20connected%20to%20this%20hub%20site%3C%2FLI%3E%3C%2FUL%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-236784%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EHub%20sites%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENews%20web%20part%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPages%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-277862%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-277862%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3Ethis%20is%20great%2C%20the%20bug%20is%20fixed%2C%20%E2%80%A6%20but%20now%20I%20am%20wondering%20if%20there%20is%20a%20way%20to%26nbsp%3Bkeep%20the%20same%20filter%20even%20if%20the%20%22Show%20All%22%20link%20is%20clicked%3F%3C%2FP%3E%3CP%3EIn%20other%20words%2C%20the%20news%20web%20part%20filter%20is%20set%20and%20working%20as%20long%20as%20the%20user%20does%20not%20click%20the%20%22Show%20All%22%20link.%20There%20appear%20to%20be%20no%20filter%20option%20in%20the%20%22Show%20All%22%20view%20of%20the%20news%20items.%20In%20my%20mind%20it%20should%20keep%20the%20filter%20from%20the%20web%20part%20it%20was%20called%20from...!%3F!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-275409%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-275409%22%20slang%3D%22en-US%22%3E%3CP%3EThanks!!%26nbsp%3B%20I%20did%20not%20have%20time%20to%20re-test%20it%20until%20today%2C%20but%20it%20is%20working%20in%20my%20tenant%20as%20well.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-275189%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-275189%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20is%20working%20again%20on%20our%20tenant.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-271319%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-271319%22%20slang%3D%22en-US%22%3E%3CP%3EI%20think%20this%20issue%20has%20been%20fixed%20now.%20When%20loading%20the%20news%20this%20morning%20the%20filters%20appear%20to%20work%20correctly%20on%20my%20targeted%20release%20tenant.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPaul%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270021%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270021%22%20slang%3D%22en-US%22%3E%3CP%3EI%20had%20a%20support%20ticket%20that%20is%20closed%20now.%26nbsp%3B%20They%20admitted%20it%20is%20a%20bug%20and%20have%20elevated%20it%20to%20the%20developers.%26nbsp%3B%20I%20found%20that%20I%20could%20use%20the%20filter%20on%20a%20modern%20team%20site%2C%20but%20not%20on%20a%20communications%20site.%26nbsp%3B%20We%20had%20our%20intranet%20launch%20so%20had%20to%20do%20so%20without%20filtering%20out%20our%20news.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-269801%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-269801%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20found%20this%20as%20well%2C%20and%20raised%20with%20MS%20Support%2C%20its%20easily%20re-producible.%26nbsp%3BIf%20you%20refresh%20the%20page%2C%20the%20data%20loads%20differently%20some%20of%20the%20filters%20are%20respected.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20no%20answer%2C%20I%20am%20seeing%20this%20on%20multiple%20tenants.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPaul%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-269765%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-269765%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20running%20into%20the%20same%20problem.%20I%20noticed%20that%20the%20filter%20function%20works%20initially%20and%20stops%20working%20after%20a%20navigating%20away%20and%20then%20back%20to%20the%20page%20with%20the%20news%20web%20part.%20The%20%22show%20all%22%20link%20is%20also%20not%20visible%20initially%20(when%20the%20filter%20is%20working)%2C%20but%20appears%20after%20navigating%20back%20to%20the%20page%20(filter%20not%20working).%3C%2FP%3E%3CP%3ESo%2C%20is%20this%20a%20bug%20or%20a%20feature%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-238698%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-238698%22%20slang%3D%22en-US%22%3E%3CP%3EI%20had%20the%20same%20requirement%20-%20needed%20featured%20news%20and%20additional%20news%20separated.%26nbsp%3B%20I%20created%20a%20site%20column%20called%20featured%2C%20then%20had%20to%20go%20through%20the%20whole%20process%20of%20making%20the%20column%20a%20managed%20property.%26nbsp%3B%20I%20had%20to%20re-index%20the%20document%20library%20and%20wait%20for%20a%20crawl%20before%20it%20would%20work.%26nbsp%3B%20It%20appears%20to%20be%20working%20now%2C%20but%20I%20lost%20some%20of%20the%20functionality%20of%20the%20News%20web%20part.%26nbsp%3B%20Since%20I'm%20the%20only%20one%20here%20on%20first%20release%2C%20I%20can't%20push%20out%20the%20settings%20that%20were%20recently%20announced.%26nbsp%3B%20I%20also%20lost%20the%20See%20all%20link%20you%20get%20with%20the%20News%20web%20part%2C%20so%20had%20to%20create%20a%20link%20to%20go%20to%20the%20See%20all%20page%20so%20I%20could%20use%20the%20email%20digest%20feature.%26nbsp%3B%20So%20it%20may%20be%20you%20just%20need%20to%20make%20sure%20your%20column%20is%20a%20managed%20property.%26nbsp%3B%20Unfortunately%20you%20have%20to%20wait%20for%20the%20crawl%20to%20run%20before%20items%20show%20up%20in%20the%20correct%20place.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-238526%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-238526%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20exactly%20same%20issue%26nbsp%3Band%20I%20haven't%20found%20any%26nbsp%3Bsolution%20so%20far.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-237063%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-237063%22%20slang%3D%22en-US%22%3EThat%20feature%20is%20fairly%20new%2C%20so%20It%20might%20be%20bugged.%20If%20you%20can%20reproduce%20it%20every%20time%20I%20would%20put%20in%20a%20support%20ticket%20and%20get%20it%20looked%20at%20cause%20it%20sounds%20like%20something%20you%20won't%20be%20able%20to%20fix.%3CBR%20%2F%3E%3CBR%20%2F%3EAs%20for%20the%20Highlighted%20content%20view%2C%20if%20you%20use%20the%20Document%20Type%2C%20or%20Type%20as%20News%20instead%20of%20document%2C%20it%20should%20render%20the%20photos%20just%20like%20news%20articles%2C%20however%20it%20doesn't%20do%20it%20exactly%20the%20same%20but%20something%20you%20could%20try.%3CBR%20%2F%3E%3CBR%20%2F%3EWhat%20I've%20done%20in%20the%20past%20that's%20worked%20well%20before%20page%20properties%20came%20out%20was%20have%20comm%20sites%20for%20each%20type%2C%20then%20just%20use%20the%20selected%20site%20option%20to%20display%20the%20news%20from%20those%20sites%20only%2C%20which%20works%20well%20and%20I've%20left%20it%20that%20way%20for%20now%2C%20so%20that's%20an%20alternative%20solution%20as%20well.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-729053%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-729053%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F2813%22%20target%3D%22_blank%22%3E%40Carol%20DeMuth%3C%2FA%3EI%20noticed%20this%20thread%20is%20a%20little%20old%20but%20we%20are%20seeing%20this%20same%20issue%20as%20well.%26nbsp%3B%20Is%20the%20filtering%20still%20working%20as%20you%20expected%20on%20News%3F%26nbsp%3B%20Did%20Microsoft%20provide%20any%20insight%20on%20what%20they%20did%20to%20fix%3F%26nbsp%3B%20Just%20wonder%20if%20or%20why%20this%20might%20not%20have%20been%20rolled%20out%20to%20all%20tenants.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-773637%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-773637%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F368468%22%20target%3D%22_blank%22%3E%40bogeorge%3C%2FA%3E%26nbsp%3B%20it%20looks%20like%20the%20bug%20is%20back.%3C%2FP%3E%3CP%3EI%20have%20two%20news%20web%20parts%20on%20the%20page.%20The%20filtering%20of%20the%20first%20one%20is%20being%20applied%20to%20the%20second%20one.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-773676%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-773676%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F368468%22%20target%3D%22_blank%22%3E%40bogeorge%3C%2FA%3E%26nbsp%3BWe%20gave%20up%20since%20it%20was%20it%20was%20not%20working%20correctly.%26nbsp%3B%20Now%20we%20have%20all%20the%20news%20in%20one%20Web%20part%20-%20But%20we%20use%20the%20feature%20on%20the%20web%20part%20edit%20to%20organize%20the%20news%20so%20the%20most%20important%20goes%20to%20the%20top.%26nbsp%3B%20I%20also%20attended%20a%20session%2Flab%20at%20the%20SP%20Conference%20in%20May%20about%20site%20pages%2Fdesigns%20and%20got%20some%20ideas%20from%20the%20people%20actually%20working%20on%20the%20pages.%26nbsp%3B%20This%20is%20a%20great%20reference%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fsharepointlookbook.azurewebsites.net%2F%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3ESharePoint%20LookBook%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EI%20think%20they%20are%20working%20on%20improving%20this%20since%20some%20of%20the%20people%20gave%20them%20feed%20back%20on%20this.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-773694%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-773694%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F2813%22%20target%3D%22_blank%22%3E%40Carol%20DeMuth%3C%2FA%3E%26nbsp%3BI've%20been%20playing%20with%20it%20still%20and%20it's%20only%20when%20the%20first%20news%20web%20part%20is%20a%20%3CSTRONG%3Ecarousel%3C%2FSTRONG%3Ethat%20it%20messes%20up%20the%202nd%20news%20web%20part.%3C%2FP%3E%3CP%3EThanks%20for%20the%20info.%20I've%20seen%20the%20LookBook%20before%2C%20very%20useful!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-778336%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20news%20web%20parts%20with%20a%20filter%20on%20a%20homepage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-778336%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F2813%22%20target%3D%22_blank%22%3E%40Carol%20DeMuth%3C%2FA%3E%26amp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F382181%22%20target%3D%22_blank%22%3E%40MartinDAZN%3C%2FA%3E%26nbsp%3B%20I%20finally%20got%20to%20the%20bottom%20of%20my%20particular%20issue.%26nbsp%3B%20I%20was%20actually%20using%20the%20PnP%20Provisioning%20Engine%20to%20update%20home%20pages%2C%20including%20adding%20News%20web%20parts%20with%20filtering.%26nbsp%3B%20What%20I%20ultimately%20discovered%20is%20that%20there%20are%202%20different%20News%20web%20parts.%26nbsp%3B%20One%20is%20a%20%22Newsfeed%22%20webpart%20and%20then%20there%20is%20a%20newer%20%22News%22%20webpart.%26nbsp%3B%20The%20older%20%22Newsreel%22%20was%20being%20added%20via%20PnP%20rather%20than%20newer%20%22News%22%20which%20was%20added%20via%20the%20UI.%26nbsp%3B%20It%20seems%20the%20newer%20version%20works%20with%20filtering%20and%20the%20old%20does%20not.%26nbsp%3B%20There%20is%20a%20nifty%20querystring%20you%20can%20add%20%3Fmaintenancemode%3Dtrue%20that%20allows%20you%20to%20see%20all%20the%20web%20part%20properties%2C%20json%20etc%20that%20helped%20in%20some%20of%20this%20troubleshooting.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20ended%20up%20writing%20a%20blog%20post%20on%20my%20particular%20saga%20and%20in%20it%20I%20also%20linked%20to%20some%20GitHub%20issues%20I%20logged%20with%20the%20PnP%20Site%20Core%20in%20case%20you%20want%20to%20read%20up%20more%20on%20my%20journey%20to%20solve%20my%20issue.%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fthreewill.com%2Fpnp-provisioning-news-filtering-api-troubleshooting%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fthreewill.com%2Fpnp-provisioning-news-filtering-api-troubleshooting%2F%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi all,

Currently we are in the middle of creating a new intranet. One of the functionalities is the ability to show news in 3 columns depending on the type of news. Therefor we created a site column 'News category' with the following choices:

  • Breaking
  • Daily
  • Other

This is working perfectly and we can tag the news pages using the new feature Page Details. Now we want to show the correct news in the correct column on the homepage. So we add the news web part in 3 different column and select the following settings:

 

  • Source: this site
  • Layout: list
  • Amount of news: 4
  • Filter
    • Page properties
    • News category is equal too Breaking (or Daily or Other, depending on which news web part we are configuring)

This seems to work perfectly after configuring the web parts and publishing the page. The problem exists when I refresh the page or somebody else visits the page. The filters are totally mixed up. Some news that is tagged Breaking is now showing in the Daily news web part. Or some news page is being shown in Breaking, Daily and Other. 
When I check each web part setting the filters are still correctly configurated but it seems that SharePoint forget to apply the filter after publishing…

I've also tried the same functionality using the Highlighted Content web part and there it works perfectly. But then my users have to deal with the fact that on each picture the SharePoint page icon is being shown. We prefer to use the news web part for the cleaner look.

Some other details:

  • The site is a communication site
  • The site is promoted to a Hub site
  • 3 Team sites are currently connected to this hub site
15 Replies
Highlighted
That feature is fairly new, so It might be bugged. If you can reproduce it every time I would put in a support ticket and get it looked at cause it sounds like something you won't be able to fix.

As for the Highlighted content view, if you use the Document Type, or Type as News instead of document, it should render the photos just like news articles, however it doesn't do it exactly the same but something you could try.

What I've done in the past that's worked well before page properties came out was have comm sites for each type, then just use the selected site option to display the news from those sites only, which works well and I've left it that way for now, so that's an alternative solution as well.
Highlighted

I'm having exactly same issue and I haven't found any solution so far.

Highlighted

I had the same requirement - needed featured news and additional news separated.  I created a site column called featured, then had to go through the whole process of making the column a managed property.  I had to re-index the document library and wait for a crawl before it would work.  It appears to be working now, but I lost some of the functionality of the News web part.  Since I'm the only one here on first release, I can't push out the settings that were recently announced.  I also lost the See all link you get with the News web part, so had to create a link to go to the See all page so I could use the email digest feature.  So it may be you just need to make sure your column is a managed property.  Unfortunately you have to wait for the crawl to run before items show up in the correct place.

Highlighted

I am running into the same problem. I noticed that the filter function works initially and stops working after a navigating away and then back to the page with the news web part. The "show all" link is also not visible initially (when the filter is working), but appears after navigating back to the page (filter not working).

So, is this a bug or a feature?

Highlighted

Hi

 

I have found this as well, and raised with MS Support, its easily re-producible. If you refresh the page, the data loads differently some of the filters are respected.

 

I have no answer, I am seeing this on multiple tenants.

 

Paul

Highlighted
Solution

I had a support ticket that is closed now.  They admitted it is a bug and have elevated it to the developers.  I found that I could use the filter on a modern team site, but not on a communications site.  We had our intranet launch so had to do so without filtering out our news. 

Highlighted

I think this issue has been fixed now. When loading the news this morning the filters appear to work correctly on my targeted release tenant.

 

Paul

Highlighted

This is working again on our tenant.

Highlighted

Thanks!!  I did not have time to re-test it until today, but it is working in my tenant as well.

Highlighted

Hi all,

this is great, the bug is fixed, … but now I am wondering if there is a way to keep the same filter even if the "Show All" link is clicked?

In other words, the news web part filter is set and working as long as the user does not click the "Show All" link. There appear to be no filter option in the "Show All" view of the news items. In my mind it should keep the filter from the web part it was called from...!?!

Highlighted

@Carol DeMuthI noticed this thread is a little old but we are seeing this same issue as well.  Is the filtering still working as you expected on News?  Did Microsoft provide any insight on what they did to fix?  Just wonder if or why this might not have been rolled out to all tenants.

Highlighted

@bogeorge  it looks like the bug is back.

I have two news web parts on the page. The filtering of the first one is being applied to the second one.

Highlighted

@bogeorge We gave up since it was it was not working correctly.  Now we have all the news in one Web part - But we use the feature on the web part edit to organize the news so the most important goes to the top.  I also attended a session/lab at the SP Conference in May about site pages/designs and got some ideas from the people actually working on the pages.  This is a great reference SharePoint LookBook 
I think they are working on improving this since some of the people gave them feed back on this.

Highlighted

@Carol DeMuth I've been playing with it still and it's only when the first news web part is a carousel that it messes up the 2nd news web part.

Thanks for the info. I've seen the LookBook before, very useful!

 

Highlighted

@Carol DeMuth@MartinDAZN  I finally got to the bottom of my particular issue.  I was actually using the PnP Provisioning Engine to update home pages, including adding News web parts with filtering.  What I ultimately discovered is that there are 2 different News web parts.  One is a "Newsfeed" webpart and then there is a newer "News" webpart.  The older "Newsreel" was being added via PnP rather than newer "News" which was added via the UI.  It seems the newer version works with filtering and the old does not.  There is a nifty querystring you can add ?maintenancemode=true that allows you to see all the web part properties, json etc that helped in some of this troubleshooting.

I ended up writing a blog post on my particular saga and in it I also linked to some GitHub issues I logged with the PnP Site Core in case you want to read up more on my journey to solve my issue.

https://threewill.com/pnp-provisioning-news-filtering-api-troubleshooting/