Moving File to another site, and i'm losing some Metadata

%3CLINGO-SUB%20id%3D%22lingo-sub-1321114%22%20slang%3D%22en-US%22%3EMoving%20File%20to%20another%20site%2C%20and%20i'm%20losing%20some%20Metadata%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1321114%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3CBR%20%2F%3E%3CBR%20%2F%3EWe%20are%20trying%20to%20move%20sharepoint%20files%20with%20added%20metadata%2C%20to%20another%20site%20in%20our%20tenant.%3CBR%20%2F%3EI%20have%20made%20the%20same%20column%20as%20in%20the%20old%20site%2C%20and%20when%20i'm%20moving%2Fcopying%20file%20to%20the%20new%20site%2C%3CBR%20%2F%3Ethen%20i%20am%20losing%20some%20metadata%20from%20the%20files.%20The%20column%2C%20have%20the%20same%20name%20and%20properties.%3CBR%20%2F%3EBut%20for%201%20column%20i'm%20getting%20the%20metadata%2C%20and%20for%20the%20other%20not.%3CBR%20%2F%3E%3CBR%20%2F%3EIs%20there%20a%20way%20to%20fix%20this%20%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1321114%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDocument%20Library%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFiles%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1321169%22%20slang%3D%22en-US%22%3ERe%3A%20Moving%20File%20to%20another%20site%2C%20and%20i'm%20losing%20some%20Metadata%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1321169%22%20slang%3D%22en-US%22%3EI%20have%20seen%20this%20problem%20reported%20more%20times%20and%20the%20behavior%20you%20are%20having%20is%20not%20the%20expected%20one%20when%20you%20are%20moving%20files...metadata%20and%20versions%20should%20be%20moved%20too%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1945049%22%20slang%3D%22en-US%22%3ERe%3A%20Moving%20File%20to%20another%20site%2C%20and%20i'm%20losing%20some%20Metadata%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1945049%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F606404%22%20target%3D%22_blank%22%3E%40Malossi%3C%2FA%3E%26nbsp%3BI%20am%20facing%20the%20same%20issue%20where%20all%20but%20one%20of%20my%20file%20metadata%20fields%20are%20transferring%20over%20without%20issue.%20Is%20there%20any%20update%20to%20this%20issue%3F%20The%20field%20that%20I%20am%20having%20trouble%20with%20is%20an%20Indexed%20non-required%20Choice%20field.%20I%20have%20other%20Indexed%20Required%20Choice%20fields%20working%20fine%20and%20non-Indexed%20non-Required%20Text%20fields%20working%20fine.%20I'm%20uncertain%20where%20the%20gap%20is.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hello,

We are trying to move sharepoint files with added metadata, to another site in our tenant.
I have made the same column as in the old site, and when i'm moving/copying file to the new site,
then i am losing some metadata from the files. The column, have the same name and properties.
But for 1 column i'm getting the metadata, and for the other not.

Is there a way to fix this ?

2 Replies
I have seen this problem reported more times and the behavior you are having is not the expected one when you are moving files...metadata and versions should be moved too

@Malossi I am facing the same issue where all but one of my file metadata fields are transferring over without issue. Is there any update to this issue? The field that I am having trouble with is an Indexed non-required Choice field. I have other Indexed Required Choice fields working fine and non-Indexed non-Required Text fields working fine. I'm uncertain where the gap is.