Modern SharePoint List Web Parts and Custom View/Column Formatting

%3CLINGO-SUB%20id%3D%22lingo-sub-504371%22%20slang%3D%22en-US%22%3EModern%20SharePoint%20List%20Web%20Parts%20and%20Custom%20View%2FColumn%20Formatting%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-504371%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20created%20a%20number%20of%20custom%20list%20views%2C%20using%20the%20column%20formatting%20and%20view%20formatting%20capabilities%2C%20and%20used%20the%20modern%20list%20view%20web%20part%20to%20insert%20these%20custom%20views%20into%20modern%20SharePoint%20pages.%26nbsp%3B%20This%20had%20been%20working%20perfectly%20until%20today.%26nbsp%3B%20I%20noticed%20that%20the%20custom%20views%20shown%20in%20the%20web%20parts%20are%20displaying%20column%20headings%20even%20though%20I%20have%20the%20column%20headings%20hidden%20in%20the%20custom%20view%20(%3CSPAN%20class%3D%22hljs-attr%22%3E%22hideColumnHeader%22%3C%2FSPAN%3E%3CSPAN%3E%3A%20%3C%2FSPAN%3E%3CSPAN%20class%3D%22hljs-literal%22%3Etrue%3C%2FSPAN%3E%3CSPAN%3E%2C%3C%2FSPAN%3E).%26nbsp%3B%20When%20I%20look%20at%20the%20list%20itself%2C%20the%20column%20headings%20are%20hidden%2C%20but%20they%20show%20up%20in%20the%20web%20part.%26nbsp%3B%20This%20is%20happening%20on%20multiple%20tenants.%26nbsp%3B%20Anybody%20else%20having%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-504371%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-504588%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20SharePoint%20List%20Web%20Parts%20and%20Custom%20View%2FColumn%20Formatting%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-504588%22%20slang%3D%22en-US%22%3EWell%2C%20I%20think%20Microsoft%20could%20have%20updated%20the%20List%20WebPart%20that%20by%20the%20way%20is%20still%20under%20preview....something%20not%20understandable%20after%20so%20many%20months%20available%20in%20SPO%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-507745%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20SharePoint%20List%20Web%20Parts%20and%20Custom%20View%2FColumn%20Formatting%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-507745%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F330577%22%20target%3D%22_blank%22%3E%40Gary_Stewart%3C%2FA%3E%26nbsp%3BI'm%20also%20seeing%20this%20same%20thing.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20created%20a%20User%20Voice%20for%20it.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsharepoint.uservoice.com%2Fforums%2F329214-sites-and-collaboration%2Fsuggestions%2F37519351-list-web-part-is-displaying-column-headers-after-j%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsharepoint.uservoice.com%2Fforums%2F329214-sites-and-collaboration%2Fsuggestions%2F37519351-list-web-part-is-displaying-column-headers-after-j%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

I have created a number of custom list views, using the column formatting and view formatting capabilities, and used the modern list view web part to insert these custom views into modern SharePoint pages.  This had been working perfectly until today.  I noticed that the custom views shown in the web parts are displaying column headings even though I have the column headings hidden in the custom view ("hideColumnHeader": true,).  When I look at the list itself, the column headings are hidden, but they show up in the web part.  This is happening on multiple tenants.  Anybody else having this issue?

2 Replies
Highlighted
Well, I think Microsoft could have updated the List WebPart that by the way is still under preview....something not understandable after so many months available in SPO
Highlighted