SOLVED

Modern "News" Webpart - Filter options have disappeared

Highlighted
Occasional Contributor

It appears that the "Filter" options on the modern News Webpart have disappeared.  The Filter heading is still there, but nothing appears beneath it.  (see screencap below)

 

This was working as recently as a few hours ago.  Anyone else having this issue?  We're using a Sharepoint Online communications site.  It appears to impact both new and existing pages, and all browsers I've tried - IE, Edge & Chrome. 

 

screencap_newsoptions.PNG

 

20 Replies
Highlighted
I have just verified that the WebPart has the filters section as expected in a Communication Site I use for my demos
Highlighted

It appears my issue may be related to the use of ShortPoint, a 3rd party plugin. Once I deactivated "Provision Shortpoint Dashboard Dependancies" under Site Settings > Site Features, the News webpart functioned normally again. However, DO NOT DO THIS if you have Shortpoint though. It basically rendered the plugin inoperable and forced me to move my content to a fresh install. I’m currently working with the plugin provider directly to troubleshoot the original issue. 

 

(Edit: it seems that others are experiencing the same issue, even without use of outside plugins, so maybe there's more to this?)

Highlighted

@SophieSueI'm having the same problem--the filtering options are missing--but I don't have a "Provision SharePoint Dashboard Dependencies" feature to deactivate. The problem occurs on four sites that are joined as a hub. Communication sites and Team sites. I've tried disconnecting them from the hub but that doesn't make a difference.

Highlighted
Hi James. I updated my original response above. The setting I deactivated was actually “Provision SHORTpoint Dashboard Dependencies”. (It’s related to a 3rd party plugin I had installed). However, if you happen to also be using the SHORTpoint plugin, don’t make the same mistake I did. It fixed my initial issue, but basically broke the site.

You’re not using the SHORTpoint plugin as well, by any chance?
Highlighted

We're not using that plug-in, but I'm getting closer to the problem. We have a mega-menu app that we developed in-house that broke yesterday. I haven't determined the cause, but I've found that if I remove that app, the filtering options return.

Highlighted

I observed with horror the same issue, no filter function anymore on our intranet. Maybe came the problem since we got the new audience feature. Unfortuntately, i don't have any third-party things to deactivate in order to get it quickly back. It's a huge problem since we manage the several type of news on the intranet startpage with those filters. Any clue to fix this?

Highlighted
We have noticed the same thing in our Highlighted content webpart. When using the source option of "The page library on this site" we no longer have filter options, we only have the sort option. Funny thing is we have a bunch that were configured to filter by column setup and they work correctly but we are not able to edit these webparts because if we do the filter gets removed and we have no way of getting it back.

I have found a workaround. You can change the source to "This Site" and then the filters come back but you have to filter by "Managed Property" instead of column.
Highlighted

@Rick DeFoe  Ours is behaving similarly.  Parts that were setup before this issue began are still filtering correctly -- we just can't edit them or add new ones.  Unfortunately, the source-switching workaround you mentioned doesn't seem to be working for us. 

Highlighted

@SophieSue I am having the same issue. When i looked in the Browser console i found the below error message. 

 

: ***Failed to load component "7e3663cd-d533-4eb8-90ec-cefed4cd119b" (SPQueryFilter). Original error: ***Manifest not found for component id "aa0a46ec-1505-43cd-a44a-93f3a5aa460a" and version ""

 

The component id corresponds to react-dom.

Highlighted

Looks like the filters are back.  Seems to be back to normal.

Highlighted
Best Response confirmed by SophieSue (Occasional Contributor)
Solution
The filters are back, without any action from our side. It's unfortunately the 3 times in 5 months since our intranet is productive, that out-of-the-box functions are in trouble for several days without any official statement from Microsoft. Annoying! I would still rely on SP-OnPremise for highly critical services, since the transparence and the communication on the MS side concerning such bugs on SP-Online is for us not good enough.
Is there any way to be immediately informed for such trouble? The standard O365 Message Center didn't told anythings about those issues.
Highlighted

@Raphael Guisolan - Thanks!  It appears the settings are back on my end as well.  I agree, communication regarding these issues is lacking. Users are spending needless hours of troubleshooting when these issues arise---time that would not have been wasted if Microsoft had simply acknowledged the problem and confirmed that they were working on a solution.  Very frustrating.

Highlighted

@SophieSue  Our filter options have not returned. Did anyone do anything special -- like bite the head off a chicken or sacrifice a geek? This will be really bad news to one of my user groups who specifically want this feature.

 

Ah, Microsoft Peek-a-Boo rides again.

Highlighted
It seems that our options reappeared as mysteriously as they originally vanished. No changes or tinkering occurred on this end. Go figure.
Highlighted

As someone mentioned, there was a bug in the filter code which was throwing an error. 

 

We notified the product team on Twitter of this issue a couple weeks ago, and they implemented a fix within days. - Which is why you see it working now.

In regards to this issue, I believe it only occurred on "Targeted Release" tenants... in which case, it is common you may see some issues as new features are being deployed and validated. It's recommended in your production environments to be on Standard Release to maintain a stable environment.

Highlighted

@Beau Cameron Unfortunately, I DON'T see it working now. Our global admin set me up for Targeted Release, but our production environment is Standard Release. Perhaps that's the problem?

Highlighted

@lisa white  Likely. Also note it only works when getting news from "This Site"

Highlighted

I spoke too soon.  My filtering options have disappeared again, as of this morning. They were working fine last night.  :\  

Highlighted
Hello Cameron,

Thanks for your comments about the targeted release. However, the bug came back last week and our entire tenant is set on Standard Release since the beginning.
Its seems that Microsoft does not have the deployment under control. We could understand the bugs could occured, but when the same bug is coming again and again over the weeks on Standard Release Tenants, it's not serious.