Modern News not showing up

%3CLINGO-SUB%20id%3D%22lingo-sub-218392%22%20slang%3D%22en-US%22%3EModern%20News%20not%20showing%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-218392%22%20slang%3D%22en-US%22%3E%3CP%3EHey%20all!%3C%2FP%3E%3CP%3EI%20have%20an%20interesting%20problem%20with%20a%20clients%20modern%20news.%3C%2FP%3E%3CP%3EThey%20have%20two%20news%20webparts%20on%20their%20startpage.%20One%20handles%20the%20news%20of%20this%20site%20(root).%3C%2FP%3E%3CP%3EThe%20other%20gets%20its%20news%20from%20a%20seperate%20group.%20This%20webpart%20shows%20only%20one%20item%20(the%20first%20news%20item%20created).%3C%2FP%3E%3CP%3EI%20have%20tried%20adding%20a%20new%20group%2C%20a%20subsite%20and%20modifying%20these.%20However%2C%20it%20either%20doesn't%20show%20anything%20or%20it%20just%20shows%20the%20first%20item.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAll%20pages%20are%20published%20and%20have%20a%20PromotedStatus%20of%202.%3C%2FP%3E%3CP%3EAccording%20to%20this%20thread%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FSharePoint%2FNews-in-News-Web-Part-not-syndicating-site-news%2Fm-p%2F186441%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FSharePoint%2FNews-in-News-Web-Part-not-syndicating-site-news%2Fm-p%2F186441%3C%2FA%3E%3C%2FP%3E%3CP%3EEveryone%20also%20needs%20to%20have%20at%20least%20read-access%20to%20the%20root%20site%2C%20which%20they%20have.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20same%20principle%20works%20on%20our%20internal%20Sharepoint%20though.%3C%2FP%3E%3CP%3EI%20am%20totally%20stumped%20on%20what%20could%20be%20causing%20this.%3C%2FP%3E%3CP%3EAny%20ideas%20on%20what%20could%20be%20the%20culprit%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-218392%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-226027%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20News%20not%20showing%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-226027%22%20slang%3D%22en-US%22%3E%3CP%3ETalked%20to%20Microsoft%20Support%20and%20they%20did%20something%20backend%2C%20which%20seems%20to%20have%20resolved%20the%20problem.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-225708%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20News%20not%20showing%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-225708%22%20slang%3D%22en-US%22%3E%3CP%3EAny%20update%20about%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-218684%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20News%20not%20showing%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-218684%22%20slang%3D%22en-US%22%3E%3CP%3EHi.%3C%2FP%3E%3CP%3EYeah%2C%20I've%20done%20this%20too.%20Reindexed%20both%20lists%20and%20sites%20and%20created%20new%20news%20items.%3C%2FP%3E%3CP%3ESpun%20it%20over%20night%20as%20well%20but%20to%20no%20avail.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-218493%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20News%20not%20showing%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-218493%22%20slang%3D%22en-US%22%3ETry%20republishing%20another%20article%20on%20the%20site%20your%20pointing%20the%20news%20webpart%20too.%20Just%20like%20removing%20a%20news%20article%20from%20promoted%20state%202%20to%200%20won't%20remove%20it%20unless%20the%20actual%20article%20is%20modified%20to%20cause%20an%20index%20refresh%20of%20that%20item.%20If%20that's%20the%20case%2C%20might%20need%20a%20full%20reindex%20kicked%20off%20if%20it%20does%20show%20on%20an%20index%2C%20or%20manually%20editing%20and%20republishing%20the%20articles%20needed.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1472157%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20News%20not%20showing%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1472157%22%20slang%3D%22en-US%22%3E%3CP%3EWhat%20is%20the%20solution%3F%20I%20am%20having%20the%20same%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1581275%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20News%20not%20showing%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1581275%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F30766%22%20target%3D%22_blank%22%3E%40Linus%20Ahnbo%3C%2FA%3E%26nbsp%3BI'm%20having%20the%20same%20issue.%20Can%20you%20point%20me%20to%20where%20you%20got%20the%20support%20needed%3F%20I%20can't%20locate%20anywhere%20on%20the%20Microsoft%20site%20to%20contact%20them%20specifically%20about%20this%20issue%20since%20I'm%20experiencing%20it%20as%20well.%20It's%20only%20for%20guests%20to%20the%20site%2C%20though.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1602306%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20News%20not%20showing%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1602306%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20having%20the%20same%20problem.%20News%20has%20been%20published%20and%20reindexed%20but%20the%20full%20number%20of%20articles%20does%20not%20show%20up%2C%20and%20in%20fact%20decreased%20from%20yesterday%20to%20today.%20Has%20anyone%20found%20a%20concrete%20solution%3F%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F30766%22%20target%3D%22_blank%22%3E%40Linus%20Ahnbo%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1602323%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20News%20not%20showing%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1602323%22%20slang%3D%22en-US%22%3EUnfortunately%20we%20don't%20have%20a%20solution%2C%20sometimes%20reindexing%20the%20sites%20works%20for%20a%20bit.%20But%20nothing%20permanent%20as%20of%20now.%3C%2FLINGO-BODY%3E
Occasional Contributor

Hey all!

I have an interesting problem with a clients modern news.

They have two news webparts on their startpage. One handles the news of this site (root).

The other gets its news from a seperate group. This webpart shows only one item (the first news item created).

I have tried adding a new group, a subsite and modifying these. However, it either doesn't show anything or it just shows the first item.

 

All pages are published and have a PromotedStatus of 2.

According to this thread: https://techcommunity.microsoft.com/t5/SharePoint/News-in-News-Web-Part-not-syndicating-site-news/m-...

Everyone also needs to have at least read-access to the root site, which they have.

 

The same principle works on our internal Sharepoint though.

I am totally stumped on what could be causing this.

Any ideas on what could be the culprit?

8 Replies
Try republishing another article on the site your pointing the news webpart too. Just like removing a news article from promoted state 2 to 0 won't remove it unless the actual article is modified to cause an index refresh of that item. If that's the case, might need a full reindex kicked off if it does show on an index, or manually editing and republishing the articles needed.

Hi.

Yeah, I've done this too. Reindexed both lists and sites and created new news items.

Spun it over night as well but to no avail.

Any update about this issue?

Talked to Microsoft Support and they did something backend, which seems to have resolved the problem.

What is the solution? I am having the same issue.

@Linus Ahnbo I'm having the same issue. Can you point me to where you got the support needed? I can't locate anywhere on the Microsoft site to contact them specifically about this issue since I'm experiencing it as well. It's only for guests to the site, though. 

We are having the same problem. News has been published and reindexed but the full number of articles does not show up, and in fact decreased from yesterday to today. Has anyone found a concrete solution?

@Linus Ahnbo 

Unfortunately we don't have a solution, sometimes reindexing the sites works for a bit. But nothing permanent as of now.