Modern experience Filters pane for Multivalued Lookup column misbehaving

Occasional Contributor

We have an Online (M365) SharePoint, Modern experience, hosting a Document Library “DocLib”, with a [Countries] multivalued lookup column targeting column [Country] in a “Countries” List. This List also contains a [Region] column which relates any country to a specific region, and this column is imported in “DocLib” resulting in another column, [Countries:Region].

 

As [Countries] is multivalued, [Countries:Region] appears to be multivalued as well.

But filtering, using the standard Filters pane behaves strangely on [Countries:Region].

We expected to be able to filter on any individual region a document can be relating to (through the countries the document is relating to).

 

However, here is what we get:

  • Instead of individual [Region] values, we get, in the Filters pane, individual “Sets of Regions” resulting from all regions related to all countries in [Countries]
    but there is more…
    • Selecting individual Regions, work just as expected. In the picture you see Regions “Middle-East” and “Africa” selected and on the left, you can see that any document with at least one country belonging to these regions are displayed
      x.png
    • On the other hand selecting “Middle-East; Middle-East” in the Filters pane,
      which results from relating a document to both Oman and Saudi Arabia in my exemple,
      gives no result at all
      y.png

 

My expectation would be –

  • Having in the [Countries:Region] Filters pane any individual distinct regions linked to the countries the documents in the view are relating to
    THIS IS NOT WORKING
    • Also, No "combinations of regions" should appear in the pane, they do not work anyway
  • Selecting the regions in the Filters pane would keep the documents that relates at least one of these selected regions - THIS IS WORKING JUST FINE
    Except that not all regions are displayed if not appearing individually and alone on any of the document of the view!

Is this a bug? Did I miss something?

2 Replies

@Pierre Hubaut 

Hi,

Has this issue been solved?  I run into same problem with multivalued managed metadata column filtering.

 

Thanks.

Not really.
In fact, I have several columns couple with similar hierarchies for my data:
- "Countries" and "Countries:Region" but also
- "Products" and "Products:Product Line"
for some reason (which I would like to understand), the problem disappeared on "Countries"/"Countries:Region" but the problem remains, for instance, on "Products"/"Products:Product Line" on my side.