SOLVED
Home

Missing Delete this document library link

%3CLINGO-SUB%20id%3D%22lingo-sub-147395%22%20slang%3D%22en-US%22%3EMissing%20Delete%20this%20document%20library%20link%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-147395%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20a%20SPO%20site%20and%20the%20default%20Documents%20library%20does%20not%20have%20the%20%22Delete%20this%20document%20library%22%20link%20on%20the%20Library%20Settings%20page.%20Has%20anyone%20seen%20this%20before%3F%20any%20idea%20what%20would%20cause%20this%20or%20how%20to%20get%20that%20link%20restored%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-147395%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-147400%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20Delete%20this%20document%20library%20link%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-147400%22%20slang%3D%22en-US%22%3EThanks%20makes%20perfect%20sense.%20%3CBR%20%2F%3EIt%20would%20be%20great%20if%20MS%20would%20state%20this%20in%20their%20documentation.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-147398%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20Delete%20this%20document%20library%20link%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-147398%22%20slang%3D%22en-US%22%3EYour%20site%20is%20group%20connected%20so%20you%20cannot%20delete%20the%20default%20library%20because%20all%20the%20other%20services%20connected%20to%20the%20site%20rely%20on%20that%20library.l%20such%20as%20the%20group%2C%20Teams%20%2C%20planner%20all%20that.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1365728%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20Delete%20this%20document%20library%20link%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1365728%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20would%20the%20the%20scenario%20be%20if%20there%20was%20no%20group%20attached%20but%20the%20delete%20link%20was%20still%20not%20visible%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22properties.png%22%20style%3D%22width%3A%20540px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F189640i23121A736A44D156%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22properties.png%22%20alt%3D%22properties.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CHR%20%2F%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22lib_settings.png%22%20style%3D%22width%3A%20878px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F189641i2BB4AD125315BAB1%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22lib_settings.png%22%20alt%3D%22lib_settings.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Respected Contributor

We have a SPO site and the default Documents library does not have the "Delete this document library" link on the Library Settings page. Has anyone seen this before? any idea what would cause this or how to get that link restored?

3 Replies
Highlighted
Solution
Your site is group connected so you cannot delete the default library because all the other services connected to the site rely on that library.l such as the group, Teams , planner all that.
Highlighted
Thanks makes perfect sense.
It would be great if MS would state this in their documentation.
Highlighted

Hi,

 

What would the the scenario be if there was no group attached but the delete link was still not visible?

 

properties.png


lib_settings.png

 

Thanks