Microsoft list Configure Layout - Not working as expected

Copper Contributor

Hi,

I have below JSON for Microsoft list Body formatting: 

 

{
    "sections": [
        {
            "displayname": "Section 1",
            "fields": [
                "Title",
                "Model2",
                "advicedto"
            ]
        },
        {
            "displayname": "Application",
            "fields": [
                "Model",
                "Claim Adviced Date"
            ]
        },
        {
            "displayname": "Others",
            "fields": [
                "Brand"
            ]
        }
    ]
}

 

This should put Title, Model2, and Advicedto columns in Section 1. And Model, and Claim Adviced Date to the Application section. Sadly, I am not getting the expected result. Some columns are coming in the Others section, which is not defined in the JSON. Please see the below screenshot:  

rupeshadh_1-1685330733774.png

What can be a solution to this? Please help.

Thanks.

 

 

1 Reply

@rupeshadh Make sure you are using correct display names of your columns. Also check below rules & official documentation and see if it works for you.

 

  • One or more sections can be defined for a body.
  • Each section can reference one or more columns in the list or library.
  • A column can be referenced only in one section.
  • If a column is referenced in multiple sections, the first section where the column is referenced will take the precedence.
  • A column not referenced in any of the sections will be automatically referenced in the last section.
  • New columns added will be automatically referenced in the last section.

DocumentationConfigure custom body with one or more sections 


Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.