SOLVED

Microsft Lists non showing multiple line of text columns

Copper Contributor

Hi, 

I am searching for help for this problem: I have created a multiple line of text column and, when it is filled by the contents I need, says "Visualizza Voci" (my environment is set up in Italian language, but I attach a screenshot to show you what happens).

 

Can you help me in any way? I tried with setting up different kind of text characteristics (RTF, RTF "advanced") and I tried to follow different tutorials on the web, with no success.

 

Andrea_1992_0-1694516845924.png

 

Thanks in advance,

Andrea

3 Replies
best response confirmed by Andrea_1992 (Copper Contributor)
Solution

Hi @Andrea_1992 ,

you have the option "Append Changes to existing text" turned on

SvenSieverding_0-1694542345967.png


If you disable that, the view will turn back to normal.

But check if you wanted to use that option first. It appends whatever you entered into the multiline-text field to the contents of the field whenever you save and by doing so it creates a kind of history/log. That data will be lost, if you turn that option off.

Best Regards,
Sven


@SvenSieverding Thank you very much for your help...one more thing: when I paste a "table" copied from Excel, I get the possibility of viewing only, for example, a little part of the table. I tried to create conditional formatting, giving "auto" size to height and width in the JSON scheme, but I lost the "graphics" and I can see the structure of the table as its "source":

Andrea_1992_0-1694592718767.png

Any hint?

 

This is the code I used for formatting:

 

{


"elmType": "div",

"txtContent": "@currentField",

"style": {

"min-height": "1em",

"height": "auto",

"width": "auto"

}

Hi @Andrea_1992 ,

unfortunately, this is not supported.
You cannot format a rich text column with list formattings. At best it will turn out like this.

See https://learn.microsoft.com/en-us/sharepoint/dev/declarative-customization/column-formatting#support...

The following are currently not supported:

Filename (in Document Libraries)
Retention Label
Sealed columns
Multi-Line Text column with enhanced rich text


But you can format that column if you disable rich text for it....... But then you loose all the text formatting.

Best Regards,
Sven

1 best response

Accepted Solutions
best response confirmed by Andrea_1992 (Copper Contributor)
Solution

Hi @Andrea_1992 ,

you have the option "Append Changes to existing text" turned on

SvenSieverding_0-1694542345967.png


If you disable that, the view will turn back to normal.

But check if you wanted to use that option first. It appends whatever you entered into the multiline-text field to the contents of the field whenever you save and by doing so it creates a kind of history/log. That data will be lost, if you turn that option off.

Best Regards,
Sven


View solution in original post