Metadata not following documents in other libraries on SharePoint Site

%3CLINGO-SUB%20id%3D%22lingo-sub-1450356%22%20slang%3D%22en-US%22%3ERe%3A%20Metadata%20not%20following%20documents%20in%20other%20libraries%20on%20SharePoint%20Site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1450356%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F693201%22%20target%3D%22_blank%22%3E%40MaryMEGI%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EHow%20do%20you%20move%20documents%20between%20the%20libraries%20in%20the%20site%3F%3CBR%20%2F%3E-%20UI%20(browser)%3CBR%20%2F%3E-%20OneDrive%20for%20Business%3CBR%20%2F%3E-%20Power%20Automate%20(Flow)%3CBR%20%2F%3E-%20Custom%20code%20(using%20moveto)%3CBR%20%2F%3E-%20File%20Explorer%3CBR%20%2F%3E-%20...%3CBR%20%2F%3EDoes%20the%20problem%20surface%20with%20all%20document%20types%20(e.g.%20Office%2C%20PDF%2C%20..)%20or%20only%20specific%20types%3F%3CBR%20%2F%3EPaul%20%7C%20SLIM%20Applications%20(%3CA%20href%3D%22https%3A%2F%2Fwww.slimapplications.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.slimapplications.com%2F%3C%2FA%3E)%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1451230%22%20slang%3D%22en-US%22%3ERe%3A%20Metadata%20not%20following%20documents%20in%20other%20libraries%20on%20SharePoint%20Site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1451230%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F4831%22%20target%3D%22_blank%22%3E%40Paul%20de%20Jong%3C%2FA%3E%26nbsp%3Bonly%20using%20%22CopyTo%22%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1449523%22%20slang%3D%22en-US%22%3EMetadata%20not%20following%20documents%20in%20other%20libraries%20on%20SharePoint%20Site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1449523%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20built%20out%20a%20Project%20Sharepoint%20with%20multiple%20libraries%20and%20site%20columns%20so%20that%20documents%20can%20move%20between%20libraries%20for%20the%20same%20project.%26nbsp%3B%20Suddenly%2C%20I'm%20experiencing%20a%20loss%20of%20MetaData%20between%20libraries.%20individual%20library%20columns%20have%20not%20been%20touched.%20Anyone%20have%20an%20idea%20of%20what%20is%20happening%20here%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnd%20now%2C%20magically%2C%20it%20is%20fixed.%26nbsp%3B%20I%20did%20nothing.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1449523%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1452813%22%20slang%3D%22en-US%22%3ERe%3A%20Metadata%20not%20following%20documents%20in%20other%20libraries%20on%20SharePoint%20Site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1452813%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F693201%22%20target%3D%22_blank%22%3E%40MaryMEGI%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EGreat.%20Let's%20hope%20it%20is%20a%20one-off%20incident.%3CBR%20%2F%3EFYI%3A%20in%20case%20you%20use%20copyto%20you%20may%20want%20to%20look%20at%20the%26nbsp%3BCopyToUsingPath%20because%20that%20can%20handle%20%25%20and%20%23%20characters%20in%20names.%20Sooner%20or%20later%20users%20will%20start%20using%20these%20characters%20because%20they%20are%20allowed%20in%20SharePoint%20Online.%3CBR%20%2F%3EPaul%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I've built out a Project Sharepoint with multiple libraries and site columns so that documents can move between libraries for the same project.  Suddenly, I'm experiencing a loss of MetaData between libraries. individual library columns have not been touched. Anyone have an idea of what is happening here?

 

 

And now, magically, it is fixed.  I did nothing.  

2 Replies
Highlighted

@MaryMEGI 
How do you move documents between the libraries in the site?
- UI (browser)
- OneDrive for Business
- Power Automate (Flow)
- Custom code (using moveto)
- File Explorer
- ...
Does the problem surface with all document types (e.g. Office, PDF, ..) or only specific types?
Paul | SLIM Applications (https://www.slimapplications.com/)

Highlighted

@MaryMEGI 
Great. Let's hope it is a one-off incident.
FYI: in case you use copyto you may want to look at the CopyToUsingPath because that can handle % and # characters in names. Sooner or later users will start using these characters because they are allowed in SharePoint Online.
Paul