Metadata erases as you add additional metadata in a Modern SharePoint Library.

%3CLINGO-SUB%20id%3D%22lingo-sub-1107298%22%20slang%3D%22en-US%22%3EMetadata%20erases%20as%20you%20add%20additional%20metadata%20in%20a%20Modern%20SharePoint%20Library.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1107298%22%20slang%3D%22en-US%22%3E%3CP%3EAfter%20we%20add%20a%20document%20to%20a%20modern%20library%20in%20SharePoint%20we%20add%20metadata%20to%20it.%20It%20had%20worked%20fine%20for%20months%20and%20now%20as%20you%20add%20the%20metadata%20all%20existing%20metadata%20erases.%20This%20is%20true%20of%20new%20and%20old%20documents.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EExample%3A%3C%2FP%3E%3CP%3EYou%20upload%20a%20document%3C%2FP%3E%3CP%3ESelect%20it%20and%20open%20the%20details%20pane%3C%2FP%3E%3CP%3EAdd%20metadata%20one%20column%20at%20a%20time%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20first%20column%20saves%20fine%2C%20but%20once%20you%20select%20another%20column%20to%20add%20metadata%20to%20all%20the%20other%20columns%20reset.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eif%20you%20select%20%22Edit%20all%22%20it%20works%20fine.%20If%20you%20return%20to%20classic%20SharePoint%20it%20works%20fine.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20else%20encountered%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENothing%20has%20been%20changed%20in%20the%20library%20settings.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1107298%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDocument%20Library%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Senior Member

After we add a document to a modern library in SharePoint we add metadata to it. It had worked fine for months and now as you add the metadata all existing metadata erases. This is true of new and old documents. 

 

Example:

You upload a document

Select it and open the details pane

Add metadata one column at a time

 

The first column saves fine, but once you select another column to add metadata to all the other columns reset.

 

if you select "Edit all" it works fine. If you return to classic SharePoint it works fine. 

 

Has anyone else encountered this?

 

Nothing has been changed in the library settings. 

0 Replies