Managed properties do not showing values

Highlighted
New Contributor

In SharePoint 2016, I am facing an issue with managed properties that are not showing values when using content search web part or Refinement panel, I have already run full crawl but still not showing any values.. have anyone face such issue?

This issue is happening only in a production environment but it is not happening in the development environment.

4 Replies
Highlighted

@OsmanTeyeb I'm assuming you have configured the managed property to be a refined property?  If you map it to one of the RefinableStringXX managed properties does that work?

Highlighted

Dear @Steve Pucelik 

Thank you for your response. 

I already tried what you said but that one also not working.

After the full crawl, I can't search for anything neither from the list level nor the site level.

I did reindex also but that one also did not give any result.

Any idea what could be the problem?

Highlighted

@OsmanTeyeb ... please verify the following:

 

  1. Go to the Site Collection ->Settings->Search Schema under Site Collection Administration->Search the managed property(or search by column name).
  2. Check “Searchable” and “Queryable”(or one of them depends on needs), and “Retrievable”.
  3. Under Mapping setting of the following Click Add a mapping and add the crawled property that you would like to map.  Click OK.
  4. Re-index the list/library(List/Library settings->Advanced Settings->re-index list->OK) Or Re-index Site collection(Site settings->Search and Offline Availability->re-index site->OK).
  5. Wait for the completion of the re-index to see the result.

Additionally are you using any specific display templates to render the results?

Highlighted

@OsmanTeyeb 

 

Hello,

 

Did you found what is the cause of the issue ? I have quite the same.

 

Have a nice day