SOLVED

Lists - error on uploading multiple attachments individually

%3CLINGO-SUB%20id%3D%22lingo-sub-1388140%22%20slang%3D%22en-US%22%3ELists%20-%20error%20on%20uploading%20multiple%20attachments%20individually%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1388140%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20uploading%20attachments%20to%20a%20list%20in%20SharePoint%20Online%2C%20we%20are%20getting%20an%20error%20if%20the%20user%20uploads%20one%20file%2C%20then%20goes%20and%20uploads%20another.%20The%20error%20doesn't%20occur%20if%20multiple%20files%20are%20chosen%20at%20one.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20else%20see%20this%3F%20I%20haven't%20had%20much%20luck%20finding%20references%20to%20the%20error%20via%20web%20search.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%22Encountering%20issue%20when%20uploading%20attachment%20XXX%20%3A%20The%20specified%20name%20is%20already%20in%20use.%20The%20document%20or%20folder%20name%20was%20not%20changed.%20To%20change%20the%20name%20to%20a%20different%20value%2C%20close%20this%20dialog%20and%20edit%20the%20properties%20of%20the%20document%20or%20folder%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20be%20clear%2C%20they%20are%20totally%20different%20files%20-%20tried%20multiple%20variations%20of%20different%20files%20and%20different%20file%20formats%2C%20makes%20no%20difference.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20list%20item%20is%20submitted%20without%20error%20by%20the%20way%20-%20but%20users%20don't%20realise%20this%20and%20keep%20on%20resubmitting%20items.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1388140%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1390462%22%20slang%3D%22en-US%22%3ERe%3A%20Lists%20-%20error%20on%20uploading%20multiple%20attachments%20individually%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1390462%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F361257%22%20target%3D%22_blank%22%3E%40dfurler%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20seeing%20the%20same%20thing%20when%20uploading%20on%20Android%20using%20a%20browser.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUsing%20the%20SharePoint%20app%20works.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1454610%22%20slang%3D%22en-US%22%3ERe%3A%20Lists%20-%20error%20on%20uploading%20multiple%20attachments%20individually%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1454610%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F361257%22%20target%3D%22_blank%22%3E%40dfurler%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EExperiencing%20this%20exact%20same%20issue%20as%20well.%20Very%20difficult%20to%20train%20400%2B%20users%20to%20upload%20all%20documents%20at%20once.%20Additionally%2C%20we%20have%20a%20Power%20Automate%20flow%20triggering%20on%20a%20new%20list%20item%20being%20created%2C%20and%20despite%20the%20error%20message%20confusing%20the%20user%2C%20the%20flow%20is%20triggered%20because%20the%20item%20is%20still%20created.%20If%20they%20resubmit%2C%20it%20will%20create%20a%20duplicate%20item%20and%20trigger%20the%20flow%20again.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20fix%20asap!!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1454640%22%20slang%3D%22en-US%22%3ERe%3A%20Lists%20-%20error%20on%20uploading%20multiple%20attachments%20individually%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1454640%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F695595%22%20target%3D%22_blank%22%3E%40jalv4%3C%2FA%3E%26nbsp%3B%20it's%20possibly%20a%20cache-ing%20issue.%20After%20uploading%20the%20first%20document%20do%20a%20refresh%20(ctrl%2Br)%20and%20see%20if%20that%20helps.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERob%3CBR%20%2F%3ELos%20Gallardos%3CBR%20%2F%3E%3CFONT%20size%3D%222%22%20color%3D%22%23333399%22%3EMicrosoft%20Power%20Automate%20Community%20Super%20User%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1462262%22%20slang%3D%22en-US%22%3ERe%3A%20Lists%20-%20error%20on%20uploading%20multiple%20attachments%20individually%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1462262%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Rob%2C%20thanks%20for%20that%20-%20not%20really%20an%20option%20though%20when%20we%20are%20talking%20about%20training%20many%20end%20users.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1462424%22%20slang%3D%22en-US%22%3ERe%3A%20Lists%20-%20error%20on%20uploading%20multiple%20attachments%20individually%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1462424%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F361257%22%20target%3D%22_blank%22%3E%40dfurler%3C%2FA%3E%26nbsp%3BIssue%20is%20confirmed%20with%20MS.%20I%20have%20a%20ticket%20open%20with%20them%20right%20now.%20ETA%20on%20the%20fix%20is%20end%20of%20June%202020.%20Confirmed%20the%20issue%20is%20affecting%20most%20if%20not%20all%20tenants%20currently.%20Issue%20is%20with%20the%20blue%20%22save%22%20button%20at%20the%20end%20of%20the%20list%20new%20form.%20If%20you%20use%20the%20grey%20%22save%22%20on%20the%20bar%20at%20the%20top%20instead%2C%20no%20issue%20encountered.%20OP%20might%20want%20to%20try%20using%20that%20as%20a%20workaround%20for%20now.%20It%20won't%20help%20much%20in%20my%20case%20-%20we%20have%20instructed%20end%20users%20to%20only%20upload%201%20attachment%20per%20item%2Fform.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1462457%22%20slang%3D%22en-US%22%3ERe%3A%20Lists%20-%20error%20on%20uploading%20multiple%20attachments%20individually%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1462457%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F695595%22%20target%3D%22_blank%22%3E%40jalv4%3C%2FA%3E%26nbsp%3BGreat%2C%20that's%20good%20news%2C%20thanks%20for%20submitting%20the%20ticket.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20helps%20to%20know%20the%20other%20save%20button%20works%2C%20I%20think%20it%20might%20be%20easier%20to%20explain%20that%20at%20times.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

When uploading attachments to a list in SharePoint Online, we are getting an error if the user uploads one file, then goes and uploads another. The error doesn't occur if multiple files are chosen at one.

 

Anyone else see this? I haven't had much luck finding references to the error via web search.

 

"Encountering issue when uploading attachment XXX : The specified name is already in use. The document or folder name was not changed. To change the name to a different value, close this dialog and edit the properties of the document or folder"

 

To be clear, they are totally different files - tried multiple variations of different files and different file formats, makes no difference.

 

The list item is submitted without error by the way - but users don't realise this and keep on resubmitting items.

 

Thanks

6 Replies

@dfurler 

 

We are seeing the same thing when uploading on Android using a browser.

 

Using the SharePoint app works.

@dfurler 

 

Experiencing this exact same issue as well. Very difficult to train 400+ users to upload all documents at once. Additionally, we have a Power Automate flow triggering on a new list item being created, and despite the error message confusing the user, the flow is triggered because the item is still created. If they resubmit, it will create a duplicate item and trigger the flow again.

 

Please fix asap!!

@jalv4  it's possibly a cache-ing issue. After uploading the first document do a refresh (ctrl+r) and see if that helps.

 

Rob
Los Gallardos
Microsoft Power Automate Community Super User

Hi Rob, thanks for that - not really an option though when we are talking about training many end users. 

Best Response confirmed by dfurler (Occasional Contributor)
Solution

@dfurler Issue is confirmed with MS. I have a ticket open with them right now. ETA on the fix is end of June 2020. Confirmed the issue is affecting most if not all tenants currently. Issue is with the blue "save" button at the end of the list new form. If you use the grey "save" on the bar at the top instead, no issue encountered. OP might want to try using that as a workaround for now. It won't help much in my case - we have instructed end users to only upload 1 attachment per item/form.

@jalv4 Great, that's good news, thanks for submitting the ticket.

 

It helps to know the other save button works, I think it might be easier to explain that at times.