List properties web part showing unselected fields after item is edited

%3CLINGO-SUB%20id%3D%22lingo-sub-1667032%22%20slang%3D%22en-US%22%3EList%20properties%20web%20part%20showing%20unselected%20fields%20after%20item%20is%20edited%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1667032%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20noticed%20(what%20I%20think%20is)%20a%20bug%20with%20the%20'List%20properties'%20web%20part%20in%20SharePoint%20Online.%20Here's%20what%20I'm%20doing%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3EI%20add%20a%20'Document%20library'%20web%20part%20to%20a%20SharePoint%20modern%20site%20page%20and%20choose%20a%20document%20library.%3C%2FLI%3E%3CLI%3EI%20add%20a%20'List%20properties'%20web%20part%20to%20the%20same%20page.%3C%2FLI%3E%3CLI%3EI%20connect%20the%20'List%20properties'%20web%20part%20to%20the%20'Document%20library'%20web%20part.%3C%2FLI%3E%3CLI%3E%3CSPAN%3EI%20set%20'Allow%20users%20to%20edit%20list%20items'%20to%20'On'.%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3EIn%20the%20'Select%20fields%20to%20display'%20section%20of%20the%20'List%20properties'%20web%20part%2C%20I%20select%20four%20of%20the%20ten%20fields%20(my%20Document%20library%20has%20ten%20fields).%3C%2FLI%3E%3C%2FUL%3E%3CP%3EWhat%20do%20I%20expect%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3EWhen%20I%20select%20an%20item%20in%20the%20'Document%20library'%20web%20part%2C%20I%20expect%20the%20four%20fields%20that%20I%20selected%20to%20display%20in%20the%20'List%20properties'%20web%20part%20to%20appear%20for%20the%20selected%20document.%3C%2FLI%3E%3CLI%3EI%20expect%20to%20be%20able%20to%20edit%20any%20of%20those%20four%20fields.%3C%2FLI%3E%3CLI%3EWhen%20I%20finish%20making%20my%20edits%20to%20any%20or%20all%20of%20the%20four%20fields%2C%20I%20still%20only%20see%20the%20four%20fields%20I%20selected%20to%20display.%3C%2FLI%3E%3C%2FUL%3E%3CP%3EWhat%20happens%3F%3C%2FP%3E%3CUL%3E%3CLI%3EThe%20four%20fields%20that%20I%20selected%20to%26nbsp%3Bdisplay%20in%20the%20'List%20properties'%20web%20part%20to%20appear%20for%20the%20selected%20document.%3CFONT%20color%3D%22%23339966%22%3E%20%3CSTRONG%3EGOOD!%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2Fimages%2Femoticons%2Fsmile_40x40.gif%22%20alt%3D%22%3Asmile%3A%22%20title%3D%22%3Asmile%3A%22%20%2F%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3C%2FLI%3E%3CLI%3EI%20can%20edit%20any%20of%20the%20four%20fields.%20%3CFONT%20color%3D%22%23339966%22%3E%3CSTRONG%3EGOOD!%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2Fimages%2Femoticons%2Flaugh_40x40.gif%22%20alt%3D%22%3Alol%3A%22%20title%3D%22%3Alol%3A%22%20%2F%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3C%2FLI%3E%3CLI%3EWhen%20I%20finish%20my%20edits%20to%20any%20or%20all%20of%20the%20four%20fields%2C%20ALL%20of%20the%20ten%20fields%20are%20then%20displayed%20and%20are%20editable.%20%3CSTRONG%3E%3CFONT%20color%3D%22%23FF0000%22%3ENOT%20SO%20GOOD!%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2Fimages%2Femoticons%2Fsad_40x40_1.gif%22%20alt%3D%22%3Asad%3A%22%20title%3D%22%3Asad%3A%22%20%2F%3E%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20this%20a%20bug%3F%20I%20really%20think%20it%20is%20and%20if%20so%2C%20can%20someone%20at%20Microsoft%20take%20a%20look%20into%20this%20and%20hopefully%20fix%20it%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1667032%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EBUG%20Report%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDocument%20Library%20Web%20Part%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EList%20Modern%20experience%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Contributor

I've noticed (what I think is) a bug with the 'List properties' web part in SharePoint Online. Here's what I'm doing:

  • I add a 'Document library' web part to a SharePoint modern site page and choose a document library.
  • I add a 'List properties' web part to the same page.
  • I connect the 'List properties' web part to the 'Document library' web part.
  • I set 'Allow users to edit list items' to 'On'.
  • In the 'Select fields to display' section of the 'List properties' web part, I select four of the ten fields (my Document library has ten fields).

What do I expect?

  • When I select an item in the 'Document library' web part, I expect the four fields that I selected to display in the 'List properties' web part to appear for the selected document.
  • I expect to be able to edit any of those four fields.
  • When I finish making my edits to any or all of the four fields, I still only see the four fields I selected to display.

What happens?

  • The four fields that I selected to display in the 'List properties' web part to appear for the selected document. GOOD! :smile:
  • I can edit any of the four fields. GOOD! :lol:
  • When I finish my edits to any or all of the four fields, ALL of the ten fields are then displayed and are editable. NOT SO GOOD! :sad:

 

Is this a bug? I really think it is and if so, can someone at Microsoft take a look into this and hopefully fix it?

 

Thanks.

4 Replies
10 months since I posted this and no reply. The issue is still present. How do I escalate this to someone at Microsoft?
Hi Joe

I am experiencing exact same today, came here to see if anyone else in similar situation and what response is, disappointing that nobody has even acknowledged the issue!!

I'm not sure where to raise bugs but would like to know too, I'll do another post to ask

It's super frustating that I went into quite a lot of details to explain the problem and got no reply. Glad someone else is experiencing the problem as I thought I was alone (obviously I'm not glad that it is causing you problems personally!). Hopefully someone from Microsoft can comment and escalate this as an issue, and fix it!

I have the same issue. I'm adding my comment here as well in hopes that Microsoft addresses this.