Links list not sorting alphabetically by URL

%3CLINGO-SUB%20id%3D%22lingo-sub-1036630%22%20slang%3D%22en-US%22%3ELinks%20list%20not%20sorting%20alphabetically%20by%20URL%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1036630%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20migrating%20data%20from%20SP2013%20to%20SPO%2C%20(but%20I'm%20not%20sure%20that%20has%20any%20bearing%20on%20this%20problem)%2C%20and%20I%20have%20a%20problem%20with%20a%20basic%20links%20list%20that%20refuses%20to%20be%20sorted%20alphabetically.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHere%20is%20the%20list%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F159207i8850209C4E7867BC%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_2.png%22%20title%3D%22clipboard_image_2.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EAs%20you%20can%20see%20from%20the%20red%20arrow%20the%20URL%20column%20is%20set%20to%20be%20sorted%20lowest%20to%20highest%2C%20but%20it's%20still%20sorting%20off%20of%20the%20ID%20column.%26nbsp%3B%20Even%20when%20I%20set%20it%20within%20the%20view%20to%20sort%20on%20the%20URL%20it%20still%20goes%20back%20to%20sort%20by%20ID.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20change%20the%20ID%20to%20sort%20descending%20that%20works%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F159208i624B2F1DB3178726%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_3.png%22%20title%3D%22clipboard_image_3.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBut%20the%20moment%20I%20click%20on%20the%20URL%20header%20and%20select%20either%20ascending%20or%20descending%2C%20I%20am%20back%20to%20this%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F159210iE78AD02CE2685467%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_5.png%22%20title%3D%22clipboard_image_5.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENothing%20I%20can%20do%20seems%20to%20change%20this%20sort%20order%20other%20than%20the%20ID%20column.%26nbsp%3B%20I%20looked%20at%20the%20actual%20links%20and%20it's%20not%20sorting%20off%20of%20those%20either.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20stumped%20on%20this%20one.%26nbsp%3B%20Thanks%20in%20advance%20for%20any%20help.%3C%2FP%3E%3CP%3ETed%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1036630%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

I am migrating data from SP2013 to SPO, (but I'm not sure that has any bearing on this problem), and I have a problem with a basic links list that refuses to be sorted alphabetically.

 

Here is the list:

clipboard_image_2.png

As you can see from the red arrow the URL column is set to be sorted lowest to highest, but it's still sorting off of the ID column.  Even when I set it within the view to sort on the URL it still goes back to sort by ID.

 

If I change the ID to sort descending that works:

clipboard_image_3.png

 

But the moment I click on the URL header and select either ascending or descending, I am back to this:

clipboard_image_5.png

 

Nothing I can do seems to change this sort order other than the ID column.  I looked at the actual links and it's not sorting off of those either.

 

I'm stumped on this one.  Thanks in advance for any help.

Ted

 

0 Replies