Link to Advanced permissions management disappeared from SharePoint Online Manage Access menu

New Contributor

Hi, I noticed SharePoint Online document library's 'manage access' menu no longer has the 'Advanced' link to open advanced permissions management for that folder.


We have folders with unique permissions so really need to be able to manage unique permissions at the folder level.

The link was there about a week ago and now the interface has updated and the link is missing. I checked different sites and  tenants.


Before - SharePoint Online > the details pane for a file/folder > click on Manage Access > Advanced

 SharePoint Online - Advanced permissions link.png


Now: After clicking manage access, I no longer see a link to 'Advanced'.

SharePoint Online - new manage access menu.png


Is this happening to others? 
Is there another way to manage advanced permissions for a folder?







11 Replies
best response confirmed by Silvie Zhang (New Contributor)

Yes there are other posts with this. Microsoft guy chimed in said it shouldn't be that way, so my guess is it's a bug. Targeted release tenants are getting this, so you can get it back if you go back to normal release, but you'll lose new shiny's. Kind of the trade off for targets release. If it's affecting you in a negative way I would suggest putting a request in so hopefully it gets looked at quicker if it gets reported. 

Here is the other thread.

Yep, It's what Chris said...and I really hope this is a bug and not a bad design thing ^-^
Thank you so much for the quick and helpful response! What a great community. I was not able to find that thread when I searched so thanks for directing me to it. I switched to SharePoint classic view finish my folder configuration.
I have the same problem - started today - did you get a resolution ?

No resolution yet but have a work around so that I could finish configuring the permissions: I switched back to classic by clicking on 'Return to classic SharePoint' from the bottom left corner of the document library.


Once in classic, to access advanced permissions:

1. Select your file/folder

2. Click ... > click Share 

3. Click Shared with from left side menu

4. Click ADVANCED link at the bottom
Now you have the full advanced permissions menu again.

Hi all,

Absolutely not intentional :) The team is investigating now. Thanks for your patience!


Stephen Rice

OneDrive Program Manager II

Update: the 'Advanced' link is back now. It's a small link at the bottom left corner of the 'Manage Access' window for me.

Thanks Microsoft!

If it can help others...

I had the same behaviour.

On one site, I could sometimes see the Advanced link, and sometimes I could not.

For me, the Documents view was the default home page of that site.

In this case, when looking at the permissions, the "Advanced" link was not there.

In the same site, when clicking first on the "Documents" link on the left pane,

then looking at the permissions, the "Advanced" link was there.


I don't know if it is a bug or by design, but it took me a few hours to figure it out...

Now it works everytime. :o)

Document TabDocument TabHome TabHome Tab

@Andre Dube  any update on this by Microsoft ?? same issue started happening for our tenant also

Hi @bhartisemwal1990,


Can you share more about what you are seeing? To my knowledge, there haven't been any changes to either the new Manage Access pane or the Advanced link within. Thanks!


Stephen Rice

OneDrive Program Manager II

Thank you SO much. This also worked for me. I've been hammering away at this for a couple of hour.