Library entry won't save content

%3CLINGO-SUB%20id%3D%22lingo-sub-832956%22%20slang%3D%22en-US%22%3ELibrary%20entry%20won't%20save%20content%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-832956%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20quirky%20issue%20where%20I've%20created%20a%20hyperlink%20field%20to%20link%20a%20Sharepoint%20library%20item%20to%20a%20Salesforce%20KM%20item.%20I%20create%20the%20entry%20and%20save%20it%2C%20but%20it%20simply%20doesn't%20save%2C%20i.e.%20when%20I%20look%20at%20the%20Sharepoint%20item%20the%20KM%20link%20field%20is%20empty.%20Content%20Approval%20for%20this%20library%20is%20switched%20off%2C%20and%20there's%20another%20field%20that%20links%20the%20item%20to%20Jira%20that%20works%20fine.%20Can't%20figure%20out%20what%20I'm%20missing.%26nbsp%3B%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20652px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F129613i0E656C3E8AA30F0B%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22SharePointList.png%22%20title%3D%22SharePointList.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-832956%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDocument%20Library%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-833939%22%20slang%3D%22en-US%22%3ERe%3A%20Library%20entry%20won't%20save%20content%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-833939%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F401862%22%20target%3D%22_blank%22%3E%40Quotidian%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20think%20it's%20likely%20a%20security%20policy%20i.e.%20library%20items%20not%20allowed%20to%20link%20to%20external%20URL.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-833970%22%20slang%3D%22en-US%22%3ERe%3A%20Library%20entry%20won't%20save%20content%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-833970%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F401862%22%20target%3D%22_blank%22%3E%40Quotidian%3C%2FA%3Eits%20definitely%20a%20quirky%20problem%2C%20i%20tried%20replicating%20it%20and%20it%20worked%20fine%2C%20are%20these%20just%20some%20added%20columns%20in%20a%20doc%20library%20or%20is%20it%20coming%20from%20some%20custom%20or%20external%20content%20type%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20gobsmacked%20on%20it%20and%20would%20love%20to%20know%20the%20answer%20as%20well.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ealso%2C%20why%20are%20you%20using%20a%20doc%20library%20and%20not%20a%20list%3F(just%20out%20of%20curiosity)%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-834007%22%20slang%3D%22en-US%22%3ERe%3A%20Library%20entry%20won't%20save%20content%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-834007%22%20slang%3D%22en-US%22%3E%3CP%3EWell%2C%20it's%20a%20doc%20library%20because%20it's%20for%20documentation%20drafting%20and%20reviews.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt's%20a%20plain%20old%20'hyperlink%20or%20picture'%20column%2C%20set%20to%20'hyperlink'.%20I'm%20sure%20now%20that%20there's%20a%20security%20policy%20somewhere%20that%20prevents%20Sharepoint%20linking%20to%20external%20URLs%20but%20I%20don't%20know%20if%20there's%20anyone%20in%20our%20IT%20admin%20who%20will%20be%20able%20to%20address%20it.%20At%20the%20moment%2C%20it's%20an%20unsolved%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-837753%22%20slang%3D%22en-US%22%3ERe%3A%20Library%20entry%20won't%20save%20content%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-837753%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F401862%22%20target%3D%22_blank%22%3E%40Quotidian%3C%2FA%3E%26nbsp%3B%20-%20I%20solved%20this%20problem%20by%20deleting%20the%20column%20and%20re-creating%20it%20with%20a%20different%20name.%20I%20guess%20there%20must%20have%20been%20some%20problem%20at%20the%20back%20end%20but%20it%20works%20now.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

I have a quirky issue where I've created a hyperlink field to link a Sharepoint library item to a Salesforce KM item. I create the entry and save it, but it simply doesn't save, i.e. when I look at the Sharepoint item the KM link field is empty. Content Approval for this library is switched off, and there's another field that links the item to Jira that works fine. Can't figure out what I'm missing. SharePointList.png

4 Replies

@Quotidian 

 

I think it's likely a security policy i.e. library items not allowed to link to external URL.

@Quotidianits definitely a quirky problem, i tried replicating it and it worked fine, are these just some added columns in a doc library or is it coming from some custom or external content type?

 

I'm gobsmacked on it and would love to know the answer as well.

 

also, why are you using a doc library and not a list?(just out of curiosity)

Well, it's a doc library because it's for documentation drafting and reviews. 

 

It's a plain old 'hyperlink or picture' column, set to 'hyperlink'. I'm sure now that there's a security policy somewhere that prevents Sharepoint linking to external URLs but I don't know if there's anyone in our IT admin who will be able to address it. At the moment, it's an unsolved issue.

 @Quotidian  - I solved this problem by deleting the column and re-creating it with a different name. I guess there must have been some problem at the back end but it works now.