Is there a way to restore the default form on a sharepoint list using a customised list?

%3CLINGO-SUB%20id%3D%22lingo-sub-911144%22%20slang%3D%22en-US%22%3EIs%20there%20a%20way%20to%20restore%20the%20default%20form%20on%20a%20sharepoint%20list%20using%20a%20customised%20list%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-911144%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20published%20a%20PowerApps%20customised%20form%20to%20a%20SharePoint%20list%20believing%20I%20could%20switch%20back%20the%20list%20back%20to%20the%20default%20form.%20I%20should%20be%20able%20to%20do%20this.%20However%20in%20list%20settings%20%26gt%3B%20form%20settings%2C%20the%20settings%20are%20missing.%20I%20have%20'%3CSPAN%3EThe%20list%20does%20not%20have%20any%20valid%20content%20type%3C%2FSPAN%3E'%20instead.%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20problematic%20because%20this%20list%20is%20live%20and%20the%20PowerApp%20is%20nowhere%20near%20finished%20yet.%20I%20could%20really%20do%20with%20switching%20it%20back.%20Does%20anyone%20know%20how%20to%20restore%20a%20default%20list%20form%20in%20SharePoint%20or%20how%20it%20might%20have%20got%20deleted%3F%20It%20was%20there%20before%20I%20created%20the%20PowerApp.%20I%20have%20not%20intentionally%20deleted%20it.%20Thanks%20so%20much.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-911144%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EApp%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-911215%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20there%20a%20way%20to%20restore%20the%20default%20form%20on%20a%20sharepoint%20list%20using%20a%20customised%20list%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-911215%22%20slang%3D%22en-US%22%3ETray%20to%20grab%20the%20URL%20that%20allow%20to%20change%20the%20list%20form%20setting%20from%20another%20list%20and%20see%20if%20you%20can%20change%20the%20setting%20in%20the%20customized%20list%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2146072%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20there%20a%20way%20to%20restore%20the%20default%20form%20on%20a%20sharepoint%20list%20using%20a%20customised%20list%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2146072%22%20slang%3D%22en-US%22%3EI%20have%20the%20same%20issue.%20Most%20posts%20related%20to%20similar%20problem%20that%20I%20found%20on%20the%20web%20refers%20to%20the%20list%20settings%20which%20I%20do%20not%20have%20access%20from%20the%20List%20Web%20Application.%20Very%20frustrating.%20I%20feel%20like%20an%20Apple%20user%20using%20an%20Android%20application.%20Sigh!%3C%2FLINGO-BODY%3E
Occasional Contributor

I have published a PowerApps customised form to a SharePoint list believing I could switch back the list back to the default form. I should be able to do this. However in list settings > form settings, the settings are missing. I have 'The list does not have any valid content type' instead. 

This is problematic because this list is live and the PowerApp is nowhere near finished yet. I could really do with switching it back. Does anyone know how to restore a default list form in SharePoint or how it might have got deleted? It was there before I created the PowerApp. I have not intentionally deleted it. Thanks so much. 

3 Replies
Tray to grab the URL that allow to change the list form setting from another list and see if you can change the setting in the customized list

I have the same issue. Most posts related to similar problems that I found on the web refer to the list settings which I do not have access from the List Web Application. Very frustrating. I feel like an Apple user using an Android application. Sigh!

@JPhReid 
I'm sorry to say I never managed to resolve it. I just had to work quickly. The only thing that occurred to me was that my list was on a classic site, all be it, in the modern view. Spoke to Microsoft at the time and they didn't know why it had happened or a way to get my old form back.