I have a list on a SharePoint page, and it doesn't populate properly.

Copper Contributor

I have this list I need to add for this FAQ project I am on, and I am trying to figure out why the list won't generate properly. 

SulemanRocketAccount_0-1718126328612.png

I am using this JSON code to format the list and it shows up perfect on my lists. Im not a coder I used this code I found online and used Chat GPT to customize it.

 

{
"hideColumnHeader": true,
"hideListHeader": true,
"groupProps": {
"headerFormatter": {
"elmType": "div",
"attributes": {
"class": "sp-row-card"
},
"style": {
"color": "black",
"background-color": "#FAF9F9",
"flex-grow": "1",
"display": "flex",
"flex-direction": "row",
"box-sizing": "border-box",
"padding": "4px 8px 5px 8px",
"border-radius": "6px",
"align-items": "center",
"flex-wrap": "nowrap",
"overflow": "auto",
"margin": "1px 4px 4px 1px"
},
"children": [
{
"elmType": "img",
"style": {
"max-width": "24px",
"max-height": "24px",
"margin-top": "2px",
"border-radius": "2px"
}
},
{
"elmType": "div",
"children": [
{
"elmType": "span",
"style": {
"padding": "5px 5px 5px 5px",
"font-weight": "500",
"font-size": "15px"
},
"txtContent": "@group.fieldData.displayValue"
}
]
},
{
"elmType": "div",
"children": [
{
"elmType": "div",
"style": {
"display": "flex",
"flex-direction": "column",
"justify-content": "center"
}
}
]
}
]
}
}
}
 
Thanks!

 

 

2 Replies
I did but the biggest issue with that one was that I could not put links into the answer and that was essential. I actually used this one to basically start my code.