HUB Site Top navigation suddenly disappeared

Copper Contributor

I created a HUB site early last week.  It took the rest of the week for the global TOP link show up and even then, I was not able to add any additional links.  Only the default "home" link was available.  Now today, I suddenly have a different screen to manage navigation but any change I make fails with "permission denied".  But I realized something else was wrong, the top navigation links at the top of the home page to the site, under the page titile, is now gone.  This used to show the same items as the left nav column but horizontally.  The left nav does show on subpages but not the home page.   Just to add to my frustration, if I add a links in the

"Structural Navigation: Editing and Sorting"  , the link works even though I get the permissions error.  Anyone else having problems?


34 Replies

@Phillipe Nelson are you still experiencing issues? Are you using a modern site template (communication or team) or a classic site as your hub site? 


Reach out to me as i want to get to the bottom of the issues you're having. 

Have you figured this out? I am working on a demo hub site (communication site) and have the same problem. I can add links but they are not showing up. I am not seeing my associated sites (communication site and standard team site) that are associated. I added them last week.

my hub navigation hasn't disappeared, but I am unable to edit it.  When i click "Add Link", the edit screen opens up in the left column but it is empty.  Any link I add never saves.  

That is exactly what happens for me.

So our of frustration I clicked [Add link], then repeatedly added a link numerous times over and over again and finally a link stuck!.  Now I can edit them and it appears to be working as intended. 



Another Redmond shambles.

Top navigation links in hub sites and their child sites randomly disappearing and re-appearing.

For over a decade SP on-prem has had navigation providers able to deliver a comprehensive solution to hierarchy traversal UI / UX, along with the good ol' "Portal Uplink".  And now MS re-invents the wheel in the most Billy Basic piece of functionality ever, and it doesn't even work.

And all those MVP Redmond brown-nosers were hollering "Hubba-Bubba-Lubba" in excitement at the announcement of Hub Sites!

Will they ever learn?

This is a bug that a fix is in progress of rolling out to you. I will provide an update once the fix is fully rolled out. 


As a workaround, you can click on the + on the edit nav experience, then adding your links and clicking save. 


Can you please explain what you mean by "As a workaround, you can click on the + on the edit nav experience".  Or else advise me if being unable to edit the nav bar is a bug that will be fixed for everyone.  I am completely unable to edit the nav bar on my hub site. I can see 'Add link' at the top but when I click on it and then add a link and a description and save it does nothing. I have waited days for something to appear with no luck. I've tried Settings > Hub site settings but there is nothing there about the navigation bar - just the hub site navigation name. I'm on Mac and have SharePoint admin permissions. thank you. 

Having same issue here with a new hub site I created just now. Cannot edit global navigation.
Wait I just figured it out, you can't use the New link window that pops up when clicking add link, that's the part that seems bugged. Click cancel, then click the + in the menu on the left, then add the link and it saves fine. Just Don't use the one that comes up when clicking Add link initially.

Thank you! I've been struggling with this for days but it has now worked. I used the + sign and I also tried a different browser. 

Sorry for the late response, been on PTO and all of these notices were going to my junk folder.  Thanks to Outlook.  Whatever was going on, the SPO folks behind the scenes fixed it.  Turns out that when a communication site was created they where auto activating the " 

SharePoint Server Publishing Infrastructure" under site collection features.  Once the site was turned into a HUB, that feature broke the primary communication site navigation and other features.  It also affected the TOP navigation in odd ways.  Turning off or deactivating the publishing infrastructure feature brought everything back to normal. 

This has since been fixed and now when a communication site is created, the publishing infrastructure feature is NOT active by default.


I am facing this issue now. Created a Hub-Site from a newly created Communication site and can not add any links to the Hub Navigation. SharePoint Server Publishing Infrastructure feature is disabled.
Any idea how I can fix this?

I'm also experiencing this issue.  I created a new communication site today and the hub site navigation isn't saving no matter how I try to do it.

Same issue, created newly communication site, set it up as hub site. New added links are not saved in the hub site navigation. 

Publishing infrastructure is disabled, tried to add 10 links hoping one would stick, tried the "trick" with de "+", administator for the tenant as for the new communcation/hub site...


Nothing seems to work, hub site navigation is not saving the new links, getting desperate.


The stangest of all, it has worked in the past! At the begin of July, a test site was set up and the hub site nav worked fine. After testing, these sites were deleted permanently.

Now we want to start the development of the actual intranet and hub site navigation refuses to cooperate.

Mine hasn't disappeared but I can't seem to edit it anymore.  I click on edit, I think I make the changes, I press save (at the bottom of the left hand bar) and then nothing happens. There must be a glitch

Still not working here for myself or my clients... Cannot add links to the top nav. Click the 'Add link' in the top nav, then the + on the left menu, type in the link and display name, click 'Save' and it disappears with no link added. Repeat as much aas you like with the same outcome. Tried in Edge and IE, still doesn't work. 

Checked with my clients and can't edit their hub nav either, same issue. 

Created a new site in SP admin, converted it to a hub site using the Register-SPOHubSite command, and tried again... nope, still not working.

Guessing that hub sites are broken at the moment? Is there any MS updates on the situation? Presenting a big problem for my clients that are using this...

A fix for the issue of inability to edit the hub nav is rolling out now. As a workaround you can edit the hub nav from either the site content's page or any document library. 

Thanks for that Melissa, that works...