Hub Site Global Navigation Not Updating

%3CLINGO-SUB%20id%3D%22lingo-sub-2728449%22%20slang%3D%22en-US%22%3EHub%20Site%20Global%20Navigation%20Not%20Updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2728449%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20there%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20teamsite%20%22Werfkeet%22%20which%20is%20the%20main%20hub%20site.%20In%20the%20hub%20I%20have%203%20other%20Team%20sites.%20Each%20Team%20site%20is%20supposed%20to%20have%20the%20same%20global%20navigation%20at%20the%20top%20of%20the%20page.%20The%20Team%20site%20of%20the%20main%20hub%20site%20has%20the%20%22SharePoint%20Server%20Publishing%20Infrastructure%22%20feature%20enabled.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20edit%20the%20navigation%20by%20clicking%20on%20edit%20on%20the%20main%20hub%20sites%20navigationbar%20it%20doesnt%20update%20the%20navigation%20on%20all%20hub%20sites.%20I've%20been%20testing%20a%20little%20bit%20and%20found%20out%20that%20when%20I%20reset%20my%20browser's%20cashe%20it%20does%20load%20correctly%20but%20I%20can%20not%20ask%20of%20the%20entire%20company%20to%20reset%20their%20browser%20cashe%20everytime%20there's%20an%20update%20to%20the%20SharePoint%20navigation.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThings%20I've%20tried%3A%3CBR%20%2F%3E-%20Turning%20off%20cashing%20in%20the%20navigation%20element%20settings%20of%20the%20main%20hub%20site.%3CBR%20%2F%3E-%20Turning%20off%20cashing%20in%20the%20navigation%20settings%20of%20the%20main%20hub%20site.%3CBR%20%2F%3E-%20Leaving%20the%20site%20alone%20over%20night%20to%20see%20if%20the%20navigation%20did%20update%20on%20its%20own%20the%20next%20day%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20seen%20many%20posts%20about%20this%20problem%3A%3CBR%20%2F%3E-%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fsharepoint%2Fhub-site-top-navigation-suddenly-disappeared%2Fm-p%2F191249%2Fpage%2F2%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fsharepoint%2Fhub-site-top-navigation-suddenly-disappeared%2Fm-p%2F191249%2Fpage%2F2%3C%2FA%3E%3CBR%20%2F%3E-%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fsharepoint%2Fmenu-not-updating%2Fm-p%2F1309625%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fsharepoint%2Fmenu-not-updating%2Fm-p%2F1309625%3C%2FA%3E%3CBR%20%2F%3E-%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fsharepoint%2Fcannot-update-hub-site-navigation%2Fm-p%2F252314%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fsharepoint%2Fcannot-update-hub-site-navigation%2Fm-p%2F252314%3C%2FA%3E%3CBR%20%2F%3E-%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fsharepoint%2Fproblems-editing-hub-site-navigation%2Fm-p%2F252647%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fsharepoint%2Fproblems-editing-hub-site-navigation%2Fm-p%2F252647%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAll%20similar%20to%20the%20problem%20I'm%20having%20(most%20the%20exact%20same%20thing)%20and%20none%20of%20them%20have%20a%20clear%20answer%20on%20how%20to%20fix%20the%20issue%20so%20that%20I%20can%20roll%20out%20new%20navigation%20to%20everyone%20simultaniously%20and%20easily%20without%20having%20to%20ask%20employees%20to%20do%20something%20to%20be%20able%20to%20see%20the%20update%20to%20the%20navigation.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20of%20a%20solution%20to%20this%20problem%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2728449%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHub%20Site%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENavigation%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENavigation%20Menu%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESites%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Hi there,

 

I have a teamsite "Werfkeet" which is the main hub site. In the hub I have 3 other Team sites. Each Team site is supposed to have the same global navigation at the top of the page. The Team site of the main hub site has the "SharePoint Server Publishing Infrastructure" feature enabled.

 

When I edit the navigation by clicking on edit on the main hub sites navigationbar it doesnt update the navigation on all hub sites. I've been testing a little bit and found out that when I reset my browser's cashe it does load correctly but I can not ask of the entire company to reset their browser cashe everytime there's an update to the SharePoint navigation.

 

Things I've tried:
- Turning off cashing in the navigation element settings of the main hub site.
- Turning off cashing in the navigation settings of the main hub site.
- Leaving the site alone over night to see if the navigation did update on its own the next day

 

I've seen many posts about this problem:
- https://techcommunity.microsoft.com/t5/sharepoint/hub-site-top-navigation-suddenly-disappeared/m-p/1...
- https://techcommunity.microsoft.com/t5/sharepoint/menu-not-updating/m-p/1309625
- https://techcommunity.microsoft.com/t5/sharepoint/cannot-update-hub-site-navigation/m-p/252314
- https://techcommunity.microsoft.com/t5/sharepoint/problems-editing-hub-site-navigation/m-p/252647

 

All similar to the problem I'm having (most the exact same thing) and none of them have a clear answer on how to fix the issue so that I can roll out new navigation to everyone simultaniously and easily without having to ask employees to do something to be able to see the update to the navigation.

 

Does anyone know of a solution to this problem?

0 Replies