SOLVED

Hub global navigation menu items updated only on classic pages

%3CLINGO-SUB%20id%3D%22lingo-sub-2199584%22%20slang%3D%22en-US%22%3EHub%20global%20navigation%20menu%20items%20updated%20only%20on%20classic%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2199584%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20a%20test%20team%20site%20that%20we%20designated%20as%20a%20hub%2C%20giving%20it%20a%20global%20navigation%20top%20bar.%20Initially%2C%20that%20navigation%20bar%20could%20be%20easily%20edited%20by%20clicking%20on%20its%20%5BEdit%5D%20button%20where%20it%20renders%20a%20vertical%20editor%20right%20on%20the%20existing%20page%2C%20next%20to%20the%20site's%20current%20navigation%20side%20bar.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20much%20experimenting%20with%20both%20classic%20and%20modern%20items%20(e.g.%20wiki%20page%20library%2C%20wiki%20page%2C%20modern%20page)%20and%20sub%20sites%20and%20associated%20sites%2C%20the%20global%20navigation%20bar%20appears%20to%20have%20ended%20up%20in%20weird%20split%20states.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20viewing%20a%20modern%20page%2C%20the%20navigation%20bar%20is%20%3CEM%3Estuck%20with%20old%20items%3C%2FEM%3E%20that%20have%20long%20been%20deleted%2C%20re-arranged%2C%20or%20renamed.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20viewing%20a%20%3CEM%3Eclassic%20page%3C%2FEM%3E%20(e.g.%20wiki)%2C%20the%20navigation%20bar%20does%20(correctly)%20show%20the%20items%20of%20the%20latest%20revision.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFurthermore%2C%20clicking%20on%20its%20Edit%20button%20no%20longer%20pops%20out%20the%20extra%20vertical%20editor%20bar%2C%20but%20instead%20now%20goes%20to%20%3CSTRONG%3ESite%20Settings%20%26gt%3B%20Navigation%20Settings%3C%2FSTRONG%3E%20page%26nbsp%3B%2F_layouts%2F15%2FAreaNavigationSettings.aspx%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20clues%20on%20this%20change%20in%20editor%20behaviour%20and%20the%20discrepancy%20of%20the%20global%20navigation%20items%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2199584%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2201970%22%20slang%3D%22en-US%22%3ERe%3A%20Hub%20global%20navigation%20menu%20items%20updated%20only%20on%20classic%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2201970%22%20slang%3D%22en-US%22%3EOn%20further%20check%2C%20for%20the%20other%20hub%20site%20that%20is%20working%20%22properly%22%2C%20in%20its%20Site%20Settings%20there%20is%20a%20Look%20and%20Feel%20%26gt%3B%20Top%20link%20bar%20option.%3CBR%20%2F%3E%3CBR%20%2F%3EBut%20for%20the%20%22broken%22%20hub%20site%2C%20it%20does%20not%20have%20that%20option%2C%20only%20Look%20and%20Feel%20%26gt%3B%20Navigation%20as%20the%20above%20URL.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2206962%22%20slang%3D%22en-US%22%3ERe%3A%20Hub%20global%20navigation%20menu%20items%20updated%20only%20on%20classic%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2206962%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20took%20%3CEM%3Ewell%20over%2024%20hours%3C%2FEM%3E%20(closer%20to%20two%20days)%20for%20the%20modern%20pages%20to%20%22uncache%22%20and%20update%20their%20global%20navigation%20bar%20to%20match%20the%20updated%20menu%20items.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20should%20be%20an%20option%20in%20the%20Site%20Settings%20to%20invalidate%20this%20to%20force%20a%20fresh%20reload.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

We have a test team site that we designated as a hub, giving it a global navigation top bar. Initially, that navigation bar could be easily edited by clicking on its [Edit] button where it renders a vertical editor right on the existing page, next to the site's current navigation side bar.

 

After much experimenting with both classic and modern items (e.g. wiki page library, wiki page, modern page) and sub sites and associated sites, the global navigation bar appears to have ended up in weird split states.

 

When viewing a modern page, the navigation bar is stuck with old items that have long been deleted, re-arranged, or renamed.

 

When viewing a classic page (e.g. wiki), the navigation bar does (correctly) show the items of the latest revision.

 

Furthermore, clicking on its Edit button no longer pops out the extra vertical editor bar, but instead now goes to Site Settings > Navigation Settings page /_layouts/15/AreaNavigationSettings.aspx

 

Any clues on this change in editor behaviour and the discrepancy of the global navigation items?

2 Replies
On further check, for the other hub site that is working "properly", in its Site Settings there is a Look and Feel > Top link bar option.

But for the "broken" hub site, it does not have that option, only Look and Feel > Navigation as the above URL.
best response confirmed by icelava (Occasional Contributor)
Solution

It took well over 24 hours (closer to two days) for the modern pages to "uncache" and update their global navigation bar to match the updated menu items.

 

There should be an option in the Site Settings to invalidate this to force a fresh reload.