Hub associated site not syncing permissions

Brass Contributor

Hi everyone

 

I have a problem with one of the sites associated to our main intranet hub.  This hub site has around 10 sites associated with it and the option to sync hub permissions to the associated sites is turned on:

 

gjayne84_0-1650974451720.png

All the associated sites also have the permission sync option enabled:

 

gjayne84_4-1650975764704.png

 

 

This was all setup about 4/5 months ago.  However, I've noticed an issue with one of the associated sites where hub permissions no longer seem to be be syncing.  When first setup this site worked, however now if I click Site Permissions for this associated site I don't see the Hub tab as per the above image - it just shows the standard site permissions:

 

gjayne84_2-1650975378246.png

It's almost as if the permissions were syncing but something has happened in the meantime as if I go into Site Permissions for this site it still shows the Hub Visitors group in the advanced permissions section:

 

gjayne84_3-1650975496278.png

It seems that this no longer syncs any changes as any users/groups added to the Hub Visitors group recently don't have access but users added back when this was setup do have access.

 

I've confirmed that the affected site is still associated with the hub via the Site Information menu option and also via SharePoint Admin Centre.  I've tried dis-associating the site from the hub and then re-associating but this made no difference.  I also tried disabling the sync permissions option on the affected site and then re-enabling this but again this didn't work.

 

I'd be grateful if anyone has any other ideas or has come across this issue before.  Thanks in advance for your help.

 

 

1 Reply
Hi,
Unfortunately we cannot help you here since Microsoft is who manage the backend services and logit that makes the synchronization. I would suggest to open a support ticket so Microsoft can investigate what the issues are