how to display Sharepoint user's department column

%3CLINGO-SUB%20id%3D%22lingo-sub-2116802%22%20slang%3D%22en-US%22%3Ehow%20to%20display%20Sharepoint%20user's%20department%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2116802%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3EI%20have%20SharePoint%20site%20and%20its%20member.%20i%20need%20to%20organize%20users%20based%20on%20department%20column.%20All%20users%20department%20and%20job%20title%20informations%20filled%20and%20AD%20server%20user%20properties%20and%20synced%20to%20Microsoft%20365.%20But%20most%20of%20their%20department%20informations%20are%20not%20shown%20in%20SharePoint.%20What%20cause%20the%20problem%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2116802%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2120116%22%20slang%3D%22en-US%22%3ERe%3A%20how%20to%20display%20Sharepoint%20user's%20department%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2120116%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F958184%22%20target%3D%22_blank%22%3E%40badral9%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EMake%20sure%20to%20check%20the%20user%20profile%20properties%20and%20see%20what%20settings%20are%20configured%20for%20the%20specific%20metadata%20field.%20Some%20fields%20are%20hidden%20for%20end-users%20by%20default.%3CBR%20%2F%3E%3CBR%20%2F%3EYours%20sincerely%2C%3CBR%20%2F%3EAref%20Halmstrand%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2119677%22%20slang%3D%22en-US%22%3ERe%3A%20how%20to%20display%20Sharepoint%20user's%20department%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2119677%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F958184%22%20target%3D%22_blank%22%3E%40badral9%3C%2FA%3E%26nbsp%3BMake%20sure%20those%20users%20have%20their%20department%20correctly%20mapped%20in%20AD%20server.%20Since%20some%20of%20the%20user's%20details%20are%20updated%20and%20some%20are%20not%20updated%20so%20there%20is%20no%20problem%20with%20the%20field%20mapping.%20Make%20sure%20the%20SP%20UPS%20sync%20is%20running%20properly.%20Also%2C%20check%20the%20UPS%20Store%20for%20those%20users%20whose%20details%20are%20not%20updated.%20The%20issue%20could%20be%20on%20the%20sync%2C%20make%20sure%20the%20sync%20is%20running%20properly%20and%20also%20make%20sure%20the%20details%20are%20updated%20a%20long%20time%20ago%20and%20not%20recently%20after%20the%20sync%20already%20ran.%20If%20it%20is%20M365%20then%20you%20have%20to%20wait%20for%20some%20time%20because%20we%20don't%20have%20control%20over%20the%20sync.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20it%20helps%2C%20please%20like%20it%20or%20mark%20it%20as%20a%20solution%20if%20it%20resolves%20your%20clarification%20or%20issue%3CBR%20%2F%3E-Sudharsan%20K...%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hello,

I have SharePoint site and its member. i need to organize users based on department column. All users department and job title informations filled and AD server user properties and synced to Microsoft 365. But most of their department informations are not shown in SharePoint. What cause the problem?

2 Replies

@badral9 Make sure those users have their department correctly mapped in AD server. Since some of the user's details are updated and some are not updated so there is no problem with the field mapping. Make sure the SP UPS sync is running properly. Also, check the UPS Store for those users whose details are not updated. The issue could be on the sync, make sure the sync is running properly and also make sure the details are updated a long time ago and not recently after the sync already ran. If it is M365 then you have to wait for some time because we don't have control over the sync.

 

Hope it helps, please like it or mark it as a solution if it resolves your clarification or issue
-Sudharsan K...

@badral9

Make sure to check the user profile properties and see what settings are configured for the specific metadata field. Some fields are hidden for end-users by default.

Yours sincerely,
Aref Halmstrand