How do I remove a blank checkbox option for a multiple choice column type?

Occasional Contributor

I am using SP Online. I created a list, with a multiple choice column type, with 3 options in a dropdown list. I also checked the box to allow Users to select multiple items in the dropdown list.


When editing the list, and clicking in that column, Users get my 3 options PLUS a BONUS (LOL) checkbox that is blank. How do I remove this blank check box option? I did not enter anything in the choices that would provide a blank check box.


I am seeing this issue in IE 11 and Chrome and ONLY in CLASSIC mode. The issue IS NOT present in MODERN/NEW mode. Why is that?


NOTE - I do not have access to InfoPath or SP Designer.


12 Replies
Make sure you don't hit enter after the last option, or go to the end of the last option and push your delete key a couple times to make sure you get rid of any trailer whitespace. Should be good then.

@Chris Webb Thanks Chris, I tried that multiple times and still I am seeing the blank checkbox show up at the bottom of my list.

I just updated my post - I am seeing this issue in IE 11 and Chrome and ONLY in CLASSIC mode. The issue IS NOT present in MODERN/NEW mode.

@GregSimonis  Conversely, how can a blank choice be inserted into a checkbox list in Modern? I've tried ALT+255 and it doesn't insert anything. Alt+0127 shows a box character.







I'm seeing the same issue today across all our SharePoint sites in the Modern look.

No matter how many times I remove the blank option from the column settings, the blank option is still showing in both dropdowns and radio buttons.


Editing the column directly in the modern view, doesn't display the blank line in the list of choices, but the blank radio button is still showing.


For us, it started today.

@Jorge Carvalho  It's doing it to my choice columns as well. Must be something they pushed causing it, I'll report it see if they know about it. 

This appears to be an intentional change. It allows you to set choice columns back to an empty/blank value. You can set to require a value if you don't want a blank selected, but I'm going to think this is by design.
I just had this issue today, and then it appeared to revert back to "expected behavior". A temporary aberration perhaps. In any case, I hope it stays fixed now. The blank/empty choice was not a valid option for a required column.
Yup, mine as well. At least it was fixed somewhat quickly.

@Chris Webb Not so lucky at my end. Still broken. Hopefully just a replication issue that will sort itself in the coming days. Thanks for the help everyone.


Apparently it’s back for everyone again.
Argh... confirming, it has returned for me too.



Over 8 months later and still seeing it.  I do not want the user to be able to enter blank.  However, mine is a dropdown and the choices always include (empty) at the bottom of the list in Quick Edit and blank at the top of the list in regular edit, no matter what I do.  Also, it has the amusing side effect of leaving garbage in the field when the user selects (empty) e.g.,