Home site on SP + New butt drop down is missing the ability to add list, document library, page, etc

Occasional Contributor

The home site (+ New) drop down button is missing the ability to add a list, document, library, page, etc. I can't figure out why it disappeared. 

Here's the default button: 


The only option now that are available are these. What happened to the options?


9 Replies
The drop down changes from if you are on a site page that isn't the home page. The drop down only shows if you are on the "official" home page. I select the page from your Site Pages library and then pick Make this page the homepage from the menu to see if it doesn't fix it.
best response confirmed by Beau Cameron (MVP)

@lukevang Only the homepage +New button allows you to create other content libraries (lists, doc libs, apps) within your site. When viewing a given "page" or "news post" your contextual to the content you're currently viewing and therefore you're only able to create a New page (using the templates gallery) or start with a copy of this page/news post.


This is similar to document libraries, where the +New button allows you to create folders or documents, but not lists or pages.


It's (trying) to be contextually relevant to the area of SharePoint you're in.


Sounds like it's confusing you however. Love your feedback on how we could make that more clear. I think it would be equally confusing if all options were available everywhere, but love to hear from you.

Hi @lukevang,


It looks like you are on a Site Page when clicking "New" in the second image. The first image looks like you're on the home page of the site - which allows for the full range of new items.


I hope this helps.



What the others have said is probably what is happening: you are not at the home page in your site
That's what I initially thought was happening but even as I set the page as the homepage, the options are still not showing up.
It could be some other site setting. I usually solve the issue by making sure that the page is the home page. It might be time for a support ticket if there aren't any other suggestions.

@lukevang I have this exact same problem on the Home Page of the site. This problem started after I reïnstalled the standard groups with /_layouts/15/permsetup.aspx because the customer had made a mess of the site settings. Checked that the Microsoft 365-group is in the Member group that has edit rights. It looks like what is missing from the New-button are Office 365-options as creating a Planner plan, a document library, a list, etc.

What manages it that you see this options under New on the start page of a site?

@John Sanders This is not the solution to this problem, see my comment. I have this exact same problem on the home page of one of our sites.


I have found the resolution to your problem. It looks like it that the problem is the result of groupifying a classic SharePoint-site, while the standard SharePoint-groups was fiddled with by an uneducated sitemaster. (Always check this first before the groupify).

Check if the standard SHAREPOINT groups are still intact via _layouts/15/permsetup.aspx. If not, repair. Next: remove the Microsoft/Office 365-group from the Member SHAREPOINT-group via advanced permission settings. Add the Microsoft 365-group again, by using their e-mailadres []. This fixed it for me.

In groups, not site permissions, check if the Microsoft 365-group floats there, beside the SharePoint-groups. If so, remove it. You can still access groups when you open a group with site permissions, and then via left menu. Or go to /_layouts/15/groups.aspx


Assign another page as home page, then re-assign the startpage as home page.