Highlighted content Webpart - Managed Property Filter Broken?

Occasional Contributor

Hi all


I'm currently trying to configure the Highlighted Content webpart, but "Find a managed Property" Filter seems to be broken.


Earlier, i have configured the same webpart already on the same page successfully. Now, when adding another Highlighted Content Webpart to the same page, i'm not able anymore to filter by the managed property, the dropdown just remains inactive.









Regardless what i type into the find textbox, the dropdown never gets activated.




I even realized that when changing the find-Text in the "old" Webpart, the choices do not change as well, contentclass remains there. Hence there seems to be something broken with the update of the dropdown?


I tested on 2 different tenants with IE, Chrome & Firefox, all the same issue.


Anyone else facing this issue?











25 Replies

We see the same across multiple tenants. Looks like the API is not working any more.

I confirm that we also have the same problem.

I am also experiencing this issue. Has anyone found a fix or workaround yet?

It looks like the functionality of the Property Dropdown has been fixed. I'm able to filter & sort correct again.

Same for us.

But: how and why has it been broken !

It is not exactly fixed. You can not search custom managed properties anymore.

It's broken again !


This morning I'm unable to configure a new hignlited content web like this one configured previously:


On my end it is working as expected.

I can filter and sort by "Built-in" and "Custom" manged properties in the Webpart.
(Using a tenant with Standard Release)



Any news yet on this broken property filter. I want to build a new intranet an really need this webpart.

Just checked it now and I was able to configure the web part as needed. I suppose I was not correctly awaked the other day ;) Or our tennant was having a temporary problem ?

I'm finding that whether or not the managed properties work depends on the Content Type chosen.

We use this web part EXTENSIVELY and have begun to see inconsistent performance.  Sometimes the configuration page freezes the whole page as soon as you take the web part in to edit mode.  Other times the dropdowns, including managed property, are inconsistent and unreliable.


Are the API's being reworked as announced enhancements are now being rolled out?  Is there any way to get a clearer picture of what is going on?

I am using RefinableString00 to filter content in HighLight content WP, but when i provide alias name it doe not work ?

Just for your Information: 

One week ago, something has changed on the highlighted Content Webpart again. We used Wildcards to filter some Titles (e.g. Title includes the words: L0*) and this does not bring any result back anymore.


MS Support is currently investigating whether this is a bug or a new feature... :smiling_face_with_smiling_eyes:



@Harsh Damaniai never tried using alias in this context, but wouldn't be suprised if that's not supported.

I'm on a targeted release tenant, the managed property filter doesn't seem to work when using managed property alias's, you have to use the internal managed property name, RefinableStringXX etc.

@Martin Achermann 


Same on our Tenant. The ManagedProperty Filter on the Highlight WebPart does not discover the ManagedProperties it should.


@Alexander Auras 


Yep. Same here. I have a custom site column that it's not recognizing on one site (a newly created site), but it's working just fine on another site (created a month ago). Same tenant. Both modern sites with only a few differences. 

Once again, the HCWP seems to be broken.

I just tested 3 different tenants and i was not able to filter by managed property anymore.


The ugly thing is, it worked now for monthes, and suddenly stopped working on Tuesday and the customer uses this webpart to navigate to different libraries. So he's pretty blocked... :( 



@Martin Achermann 


Is this functionality still broken?


I also can't search for any Managed Property