SOLVED

Highlighted Content web part not showing document titles

%3CLINGO-SUB%20id%3D%22lingo-sub-116621%22%20slang%3D%22en-US%22%3EHighlighted%20Content%20web%20part%20not%20showing%20document%20titles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116621%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20highlighted%20content%20web%20part%20filtered%20on%20a%20managed%20property%20and%20it%20is%20showing%20all%20the%20documents%20I%20would%20expect%20it%20to.%20However%20for%205%20of%20the%20documents%20it%20is%20not%20showing%20the%20document%20file%20name%20or%20title%20(I%20have%20this%20web%20part%20displayed%20as%20a%20list).%20It%20is%20choosing%20random%20text%20in%20the%20document%20to%20display.%20For%20two%20of%20the%20documents%20is%20has%20chosen%20some%20text%20from%20the%20footer!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHow%20can%20I%20get%20this%20web%20part%20to%26nbsp%3Balways%20use%20the%20title%20of%20the%20document%20(all%20the%20documents%20have%20titles)%20or%20at%20the%20very%20least%20the%20filename%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20deleting%20the%20doc%20and%20re-uploading%20with%20no%20luck.%20I%20have%20tried%26nbsp%3Bcopying%20the%20content%20of%20the%20doc%20(it's%20just%20one%20page%20for%20all%20of%20these%20docs)%20to%20a%20new%20doc%20and%20then%20uploading%20that%20and%20still%20it%20insists%20on%20picking%20text%20from%20the%20doc%20to%20use%20as%26nbsp%3Bthe%20title%20when%20displayed%20in%20this%20web%20part.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%20appreciated!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-116621%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-153084%22%20slang%3D%22en-US%22%3ERe%3A%20Highlighted%20Content%20web%20part%20not%20showing%20document%20titles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-153084%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20Duane%2C%20this%20looks%20to%20be%20exactly%20what%20I%26nbsp%3Bam%20after.%20I%20haven't%20had%20a%20chance%20to%20make%20any%20changes%20yet%20but%20this%20perfectly%20explains%20the%20situation%20I%20had.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-152992%22%20slang%3D%22en-US%22%3ERe%3A%20Highlighted%20Content%20web%20part%20not%20showing%20document%20titles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-152992%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20I%20found%20this%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fjoannecklein.com%2F2017%2F02%2F12%2Fdemystifying-titles-in-sharepoint-search-delve%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Eblog%20%3C%2FA%3Ethat%20sorts%20the%20problem%20out.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3Ebasicly%20you%20go%20to%20search%20schema%20on%20the%26nbsp%3B%3C%2FSPAN%3E%3CEM%3Etitle%3C%2FEM%3E%3CSPAN%3E%26nbsp%3Bmanaged%20property%20settings%20and%20adjust%20the%20position%20of%20the%26nbsp%3B%3C%2FSPAN%3E%3CEM%3EMetadataExtractorTitle%3C%2FEM%3E%3CSPAN%3E%26nbsp%3Bcrawled%20property%20(or%20remove%20that%20crawled%20property%20altogether%20if%20you%20do%20not%20want%20it%20included).%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EI%20deleted%20it%20alltogether%20which%20fixed%20the%20problem.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-147153%22%20slang%3D%22en-US%22%3ERe%3A%20Highlighted%20Content%20web%20part%20not%20showing%20document%20titles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-147153%22%20slang%3D%22en-US%22%3E%3CP%3ENope%20-%20I%20sent%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F10375%22%20target%3D%22_blank%22%3E%40John%20Sanders%3C%2FA%3E%26nbsp%3Bsome%20details%20but%20haven't%20had%20a%20resolution.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-146823%22%20slang%3D%22en-US%22%3ERe%3A%20Highlighted%20Content%20web%20part%20not%20showing%20document%20titles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-146823%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EDid%20you%20manage%20to%20get%20this%20fixed%3F%20I'm%20having%20the%20same%20problem.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%3C%2FP%3E%0A%3CP%3EDuane%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-127819%22%20slang%3D%22en-US%22%3ERe%3A%20Highlighted%20Content%20web%20part%20not%20showing%20document%20titles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-127819%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20John%2C%20I've%20emailed%20you%20with%20details.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3EMark%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-127664%22%20slang%3D%22en-US%22%3ERe%3A%20Highlighted%20Content%20web%20part%20not%20showing%20document%20titles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-127664%22%20slang%3D%22en-US%22%3ESince%20you%20mention%20all%20the%20docs%20have%20titles%2C%20when%20you%20just%20manually%20search%20for%20the%20document%20in%20SharePoint%20(by%20title)%2C%20does%20the%20document%20come%20up%3F%20How%20does%20the%20title%20display%20in%20that%20situation%3F%3CBR%20%2F%3E%3CBR%20%2F%3EHighlighted%20content%20is%20using%20search%20to%20find%20and%20display%20your%20documents.%20So%20if%20it%20works%20in%20search%2C%20but%20not%20HC%2C%20we'd%20love%20to%20get%20more%20details%20and%20see%20if%20we%20can%20help%20figure%20this%20out.%20Can%20you%20PM%20me%20(note%20you%20have%20to%20allow%20PMs%20for%20me%20to%20reply)%2C%20or%20email%20me%20at%20my%20firstname.lastname%40microsoft.com%20with%20some%20screenshots%3F%3CBR%20%2F%3E%3CBR%20%2F%3EThanks!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-127648%22%20slang%3D%22en-US%22%3ERe%3A%20Highlighted%20Content%20web%20part%20not%20showing%20document%20titles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-127648%22%20slang%3D%22en-US%22%3E%3CP%3EHave%20to%20tried%20ensuring%20there%20is%20a%20title%20tagged%20on%20the%20document%20and%20tried%20to%20reindex%20the%20document%20library%3F%20(Library%20settings%20-%20Advanced%20-%20Reindex%20document%20library)%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1083444%22%20slang%3D%22en-US%22%3ERe%3A%20Highlighted%20Content%20web%20part%20not%20showing%20document%20titles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1083444%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F2441%22%20target%3D%22_blank%22%3E%40Duane%20Bergh%3C%2FA%3EThanks%20!%20it%20solved%20my%20issue%20%3A%20)%3C%2FP%3E%3CP%3EBtw%2C%20do%20u%20know%20which%20crawled%20prop%20should%20I%20add%20to%20the%20managed%20property%2C%20in%20order%20to%20include%20the%20%22name%22%20of%20the%20listitem%20(%20usually%20known%20as%20%22fileleafref%22%20)%20thanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I have a highlighted content web part filtered on a managed property and it is showing all the documents I would expect it to. However for 5 of the documents it is not showing the document file name or title (I have this web part displayed as a list). It is choosing random text in the document to display. For two of the documents is has chosen some text from the footer!

 

How can I get this web part to always use the title of the document (all the documents have titles) or at the very least the filename?

 

I have tried deleting the doc and re-uploading with no luck. I have tried copying the content of the doc (it's just one page for all of these docs) to a new doc and then uploading that and still it insists on picking text from the doc to use as the title when displayed in this web part.

 

Any ideas appreciated!

8 Replies

Have to tried ensuring there is a title tagged on the document and tried to reindex the document library? (Library settings - Advanced - Reindex document library)

Since you mention all the docs have titles, when you just manually search for the document in SharePoint (by title), does the document come up? How does the title display in that situation?

Highlighted content is using search to find and display your documents. So if it works in search, but not HC, we'd love to get more details and see if we can help figure this out. Can you PM me (note you have to allow PMs for me to reply), or email me at my firstname.lastname@microsoft.com with some screenshots?

Thanks!

Thanks John, I've emailed you with details.

 

Regards,

Mark

Hi,

 

Did you manage to get this fixed? I'm having the same problem.

 

Thanks

Duane

Nope - I sent @John Sanders some details but haven't had a resolution.

Best Response confirmed by Mark Thorn (Occasional Contributor)
Solution

Hi, I found this blog that sorts the problem out.

 

 

basicly you go to search schema on the title managed property settings and adjust the position of the MetadataExtractorTitle crawled property (or remove that crawled property altogether if you do not want it included).

 

I deleted it alltogether which fixed the problem.

Thanks Duane, this looks to be exactly what I am after. I haven't had a chance to make any changes yet but this perfectly explains the situation I had.

 

@Duane BerghThanks ! it solved my issue : )

Btw, do u know which crawled prop should I add to the managed property, in order to include the "name" of the listitem ( usually known as "fileleafref" ) thanks!