hide formula on new entry form gives wrong today date

%3CLINGO-SUB%20id%3D%22lingo-sub-2353925%22%20slang%3D%22en-US%22%3Ehide%20formula%20on%20new%20entry%20form%20gives%20wrong%20today%20date%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2353925%22%20slang%3D%22en-US%22%3E%3CP%3Ei%20have%20a%20list%20column%20with%20a%20date%20field%20that%20i%20hide%20when%20a%20new%20item%20is%20created.%3C%2FP%3E%3CP%3E%3Dif(%5B%24Status%5D%3D%3D'Pending'%2C'false'%2C%20'true')%3C%2FP%3E%3CP%3Ethe%20date%20field%20is%20set%20to%20default%20value%20%22today%C2%B4s%20date%22.%3C%2FP%3E%3CP%3Ewhen%20i%20create%26nbsp%3B%20a%20new%20item%20the%20date%20field%20is%20hidden%20but%20when%20i%20save%20it%2C%20it%20writes%20the%20wrong%20time.%3C%2FP%3E%3CP%3Ethe%20time%20is%20always%20the%20full%20hour%20next%20(ex.%20if%20time%20is%209%3A23%20it%20shows%2010%20ecc.)%3C%2FP%3E%3CP%3Ewhithout%20the%20hide%20formula%20(date%20field%20is%20visible%20creating%20a%20new%20item)%20the%20time%20is%20ok.%3C%2FP%3E%3CP%3Ewhat%20is%20wrong%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Etx%20for%20any%20help%3C%2FP%3E%3CP%3Ekurt%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2353925%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2355597%22%20slang%3D%22en-US%22%3ERe%3A%20hide%20formula%20on%20new%20entry%20form%20gives%20wrong%20today%20date%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2355597%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F921257%22%20target%3D%22_blank%22%3E%40kuno66%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20this%20on%20my%20SharePoint%20tenant%20%26amp%3B%20I%20can%20reproduce%20this%20issue.%3C%2FP%3E%3CP%3EBelow%20are%20my%20test%20results%2C%20where%20both%20dates%20have%20default%20value%20set%20to%20%22Today's%20date%22%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22Conditional%20date%20column%20with%20today's%20date.PNG%22%20style%3D%22width%3A%20578px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F280765iA4BBACCD3372D8BF%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Conditional%20date%20column%20with%20today's%20date.PNG%22%20alt%3D%22Conditional%20date%20column%20with%20today's%20date.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20will%20suggest%20you%20to%20see%20if%20your%20regional%20settings%20are%20different%20than%20regional%20settings%20of%20SharePoint%20site.%3C%2FP%3E%3CP%3EFor%20more%20information%2C%20check%20below%20documentations%3A%3C%2FP%3E%3COL%3E%3CLI%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Fchange-your-personal-language-and-region-settings-caa1fccc-bcdb-42f3-9e5b-45957647ffd7%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3EChange%20your%20personal%20language%20and%20region%20settings%3C%2FA%3E%3C%2FLI%3E%3CLI%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Fchange-regional-settings-for-a-site-e9e189c7-16e3-45d3-a090-770be6e83c1a%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3EChange%20regional%20settings%20for%20a%20site%3C%2FA%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3EIf%20that%20does%20not%20solve%20your%20issue%2C%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fhome%2Fcontact%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3EContact%20Office%20Support%3C%2FA%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Eor%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoft-365%2Fbusiness-video%2Fget-help-support%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3EGet%20support%3C%2FA%3E.%3C%2FP%3E%3CHR%20%2F%3E%3CP%3EPlease%20click%26nbsp%3B%3CSTRONG%3EMark%20as%20Best%20Response%3C%2FSTRONG%3E%26nbsp%3B%26amp%3B%20%3CSTRONG%3ELike%3C%2FSTRONG%3E%20if%20my%20post%20helped%20you%20to%20solve%20your%20issue.%20This%20will%20help%20others%20to%20find%20the%20correct%20solution%20easily.%20It%20also%20closes%20the%20item.%20If%20the%20post%20was%20useful%20in%20other%20ways%2C%20please%20consider%20giving%20it%20%3CSTRONG%3ELike%3C%2FSTRONG%3E.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

i have a list column with a date field that i hide when a new item is created.

=if([$Status]=='Pending','false', 'true')

the date field is set to default value "today´s date".

when i create  a new item the date field is hidden but when i save it, it writes the wrong time.

the time is always the full hour next (ex. if time is 9:23 it shows 10 ecc.)

whithout the hide formula (date field is visible creating a new item) the time is ok.

what is wrong?

 

tx for any help

kurt

2 Replies

@kuno66 

I tried this on my SharePoint tenant & I can reproduce this issue.

Below are my test results, where both dates have default value set to "Today's date":

 

Conditional date column with today's date.PNG

 

I will suggest you to see if your regional settings are different than regional settings of SharePoint site.

For more information, check below documentations:

  1. Change your personal language and region settings
  2. Change regional settings for a site

If that does not solve your issue, Contact Office Support or Get support.


Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

i changed the settings. for the online profile and local.
but non result.
by the way local settings were ok. online settings also.
i changed them still to the europe settings.
but always wrong date.
i waited for about 2 hours that the settings takte effekt.

regards kurt