Global Admin "You need permission"

%3CLINGO-SUB%20id%3D%22lingo-sub-2939585%22%20slang%3D%22en-US%22%3EGlobal%20Admin%20%22You%20need%20permission%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2939585%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20setting%20up%20Sharepoint%20for%20a%20client.%26nbsp%3B%20I'm%20setup%20as%20global%20admin.%26nbsp%3B%20Through%20M365%20admin%20center%20I%20created%20a%20new%20Sharepoint%20site.%26nbsp%3B%20I%20was%20able%20to%20access%20it.%26nbsp%3B%20I%20added%20the%20users%20and%20started%20migrating%20data.%26nbsp%3B%20Now%20when%20I%20try%20to%20access%20the%20site%20with%20my%20global%20admin%20account%20it's%20saying%20I%20need%20permission.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20request%20permission%2C%20but%20the%20issue%20is%20that%20account%20it%20tied%20to%20a%20%22onmicrosoft.com%22%20address%2C%20so%20I%20don't%20get%20emails.%26nbsp%3B%20I%20was%20under%20the%20impression%20that%20I%20didn't%20have%20to%20purchase%20an%20additional%20license%20as%20an%20admin.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3EI%20don't%20understand%20why%20if%20I%20created%20the%20SP%20site%2C%20why%20I%20now%20need%20to%20have%20permission.%3C%2FP%3E%3CP%3EAny%20help%20would%20be%20appreciated.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2939585%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2939907%22%20slang%3D%22en-US%22%3ERe%3A%20Global%20Admin%20%22You%20need%20permission%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2939907%22%20slang%3D%22en-US%22%3EHello!%3CBR%20%2F%3ECreating%20the%20site%20does%20not%20necessarily%20add%20all%20the%20Global%20admin%20users%20the%20required%20permissions%20to%20access%20it.%3CBR%20%2F%3EIf%20you%20need%20access%20and%20you%20have%20GA%20privileges%20the%20best%20would%20be%20to%20add%20yourself%20using%20the%20SPO%20admin%20panel%3C%2FLINGO-BODY%3E
Occasional Visitor

I'm setting up Sharepoint for a client.  I'm setup as global admin.  Through M365 admin center I created a new Sharepoint site.  I was able to access it.  I added the users and started migrating data.  Now when I try to access the site with my global admin account it's saying I need permission. 

I request permission, but the issue is that account it tied to a "onmicrosoft.com" address, so I don't get emails.  I was under the impression that I didn't have to purchase an additional license as an admin.  

I don't understand why if I created the SP site, why I now need to have permission.

Any help would be appreciated. 

1 Reply
Hello!
Creating the site does not necessarily add all the Global admin users the required permissions to access it.
If you need access and you have GA privileges the best would be to add yourself using the SPO admin panel