Flow button in SharePoint list stops working after the first click

New Contributor

I have added a flow button to a SharePoint list using column formatting (JSON). The first click of the button in a row works absolutely fine and the panel to run the flow is shown. If I click cancel and then click on the same link again, the link is dead. This is repeatable for each and every row in the SharePoint list with the link in the row being killed after the first click.

 

I'm guessing this is a bug, I have tried on a couple of tenants on a couple of different browsers.

 

Thanks D.

5 Replies

@DavidPGrover yes I've got the same behaviour and it does appear to be a bug. I'm working round it by refreshing the browser (ctrl+r) and then clicking the button again which works.

 

Rob
Los Gallardos
Intranet, SharePoint, Website and Power Platform Manager (and classic 1967 Morris Traveller driver)

 

 

Interestingly if you append the URL with the search view i.e. /AllItems.aspx?view=7, it works fine. Not really a fix. Will have to wait until MS fixes it I guess.
Hi everyone. I have the same issue. Everything is working "fine". I shared with other users and they can execute the flow. But when I close the flow tab and I want to click the button again. The tab no longer appears. I have to reload the page to click the button and have the tab appear.
Any update about this issue?
Greetings.
Well...I raised with MS support but no surprise they closed the ticket suggesting no issue. I have since posted it as an issue here https://github.com/SharePoint/sp-dev-docs/issues/7139 as it's clearly a bug.
Same issue happening here! Funny seeing this was already reported 1 month ago and still not fixed.

Opened a support ticket in Microsoft and waiting for being escalated, will see how that goes.