Filtering by Person/Group does not return results

Occasional Contributor

I clicked on "Person/Group" column and manually typed in a person's name. I waited for the results to appear and then clicked on the name I wanted.  I can see in the header that 1 value has been selected.  I then clicked "Apply" and was returned to the list with zero results.  I clicked on the "Person/Group" column again and then scrolled down to find the name I wanted.  I ticked the box and can now see in the header that 2 values have been selected.  I clicked "Apply" and now can see the list filtered by the name I had just selected.  Why is the first method or typing in name and selecting from list not working?

7 Replies
Sounds like you possibly have 2 entries for the same user in your directory? Possibly a guest user or something that you may be selecting when searching?

@Chris Webb I randomly selected 3 different users, with the same result.  I cannot confirm 100% if they have guest accounts too, but I do doubt it... how do I check this or what else can I do?

Do you have your column settings to allow all users or some other option for available users you can use to populate the list?

@Chris Webb All I did was create a new column, select it as Person/Group type and then at the option of "Choose from", I checked "All Users".  The other option was "SharePoint Group".

Note that my list has about 4000 rows.

I went into a test list of about 20 rows and did the same thing on the Person/Group column.  Method 1 of type name and select, worked!  Could this be related to the size of the list?

Don't think so I have a list that's got over 4000 items and a person column that is filtering just fine. I'm wanting to lean towards some data issues, but I don't see how that would be since it kind of forces you to have proper data in the list, at least I think it does. Maybe export to Excel the list and check the column for some odd data in that column?

@Chris Webb I exported to Excel and eyeballed the values - they all look to be valid addresses with  There are some rows which are blank, which is expected as this is not a mandatory field. 

@Chris Webb Oh! I found something: my column is Person/Group Type and I chose to display the work email ID, i.e. "" instead of "Tan, Mei".  When I filtered and selected my name from the results list, I see that "Tan, Mei" is ticked but "" is not ticked.  This is why the filter returned zero results!  How do I work around this?  I must have the email address displayed to ensure people are selecting the correct person since it is possible for duplicates of Last Name, First Name.