File types previously uploaded to Sharepoint are not recognised and simply detailed as "File"

New Contributor

I'm trying to access some InDesign files previously uploaded to Sharepoint by another colleague. They appear on Sharepoint as an unrecognised file and still do so when downloaded, their file type is simply listed as "File" (see screenshots)


I have the software to use them (InDesign) but they won't open when I try to open with that. Any ideas?

5 Replies
best response confirmed by ianfillingham (New Contributor)


They might be missing the file extension.  If you download one, rename it and add the Indesign file extension, I suspect they'll start working again.

@Steven Andrews Thanks a lot for the suggestion! Sadly just tried and that didn't work


Have you got a file that doesn't contain anything personal or business sensitive that I can look at?  I'm happy to provide an email address to send it too.  I've got SharePoint Online and Adobe Creative Cloud with Indesign so can have a look at it.


Once cracked I'll let you know and the wider community as well should anyone else have the issue.

@Steven Andrews just had a look and I'd added the file extension to the wrong file. Just added the .indd extension to the file I was having a problem opening and it worked - problem solved! Thanks so much

No problem, glad it helped. Would you mind marking the post as the best answer when you've a sec. For community assistance and personal vanity :p