External user permission error

Kanwar Jot Singh

We have a sharepoint online tenant, In which one sitecollection is shared externally to certain domains. For most of the domains and users it is working fine when we share the external user contribute permission.


But for one domain which has one active user when the sub site is shared as contribute or even owner it shows shared but with a lot of Deny access. But for other external user it is just showing the contribute access allowed and not the deny. 


Now the user can see the landing page ( one list view web part , document library , contact web part)

But when it click the list and tries to go to the list page the url keeps redirecting and to and then back to the list endlessly.


I already deleted the user once then re added it but to no use, Elevated to owner permission still no use. Any suggestions would be helpful 





8 Replies

Admins can you please help 



What information do you get when checking the permissions of the user by using the Check permissions option available in the Permissions page in the site?

I can see the permission Read , contribute and list of deny permissions.



Well, the problem is clear: the user has not permissions to view items so that's the reason why he/she is having denied access when trying to browse a list. Apparently he/she has been assigned at some point of your information architecture this permission so you have to find where and do the right permission assignment

It was problem with the user role in azure AD , changed that to User which fixed the issue.


The solution for this issue is to add your own domain to the list of allowed domains( on the Tenant and to the site collection that is being shared externally. In my testing, in some cases by just populating external user's work email address in the user's profile did work and in some cases, I had to add our own domain to allowed list.


Please let me know if this solution worked for you.


Hi Kanwar - can you please share in detail what you had to do to remove the DENY? I have checked my external user too and they are marked as a user role within Azure AD. 


Hello All, I am also facing the similar issue - When given the READ only access to a external user. I am seeing the permissions are as attached. User is not able to access the site.


May i know why i am seeing the Deny permissions? How can i remove this Deny permission.


Thanks & Regards,



Related Conversations
MSTeams Groups in outlook with macros disabled
ReadyorNot in Microsoft Teams on
0 Replies
Unknown Login Error
Alex_P3462 in Microsoft Teams on
0 Replies
Spelling Pop-Up Stuck on SharePoint List
aricornish in SharePoint on
0 Replies
Problem with OneDrive
esholder in OneDrive for Business on
5 Replies