SOLVED

External user got permission but cant access page

%3CLINGO-SUB%20id%3D%22lingo-sub-1366169%22%20slang%3D%22en-US%22%3EExternal%20user%20got%20permission%20but%20cant%20access%20page%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1366169%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20invited%20a%20external%20user%20to%20a%20site%20on%20my%20sharepoint%20but%20the%20user%20get%20the%20request%20access%20page%20when%20trying%20to%20access.%3C%2FP%3E%3CP%3E%2Fsites%2FTest%2Ftestsite%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20checking%20the%20permissions%20for%20the%20external%20user%20on%20the%20site%20it%20confirms%20that%20he%20has%20Read%20permission%20and%20should%20be%20able%20to%20access%20the%20site.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20Sharepoint%20admin%20center%3A%3C%2FP%3E%3CP%3E-Policies%20%2F%20sharing%20is%20set%20to%20%22New%20and%20existing%20guests%22%3C%2FP%3E%3CP%3E-Policies%20%2F%20Limit%20external%20sharing%20by%20domain%20and%20correct%20domain%20is%20added%3C%2FP%3E%3CP%3E-Sites%20%2F%20active%20sites%2C%20the%20parent%20site%20(%2Fsites%2FTest)%20has%20%22External%20sharing%22%20set%20to%20%22on%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20Azure%20Active%20Directory%3A%3C%2FP%3E%3CP%3E-The%20external%20user%20exists%20as%20a%20guest%20user.%20Source%20%22External%20Azure%20AD%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20to%20remove%20the%20user%20and%20add%20him%20again.%3C%2FP%3E%3CP%3EI've%20tried%20to%20approve%20access%20requested%20from%20the%20the%20%22you%20need%20permission%22-%20page.%20I%20get%20a%20%22Request%20approved%22%20but%20it's%20not%20working.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20sure%20what%20setting%20I%20got%20wrong%20and%20why%20it's%20not%20working.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1366169%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPermissions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1369207%22%20slang%3D%22en-US%22%3ERe%3A%20External%20user%20got%20permission%20but%20cant%20access%20page%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1369207%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F256200%22%20target%3D%22_blank%22%3E%40ShareP1610%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3EDoes%20user%20has%20access%20to%26nbsp%3B%3CSPAN%3E%2Fsites%2FTest%20%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1369465%22%20slang%3D%22en-US%22%3ERe%3A%20External%20user%20got%20permission%20but%20cant%20access%20page%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1369465%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F70455%22%20target%3D%22_blank%22%3E%40Alireza%20Rahimifarid%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20check%20permissions%20the%20user%20got%20Read%20permission%20to%20%2Fsites%2Ftest.%20But%20cant%20logg%20on%20to%20that%20either%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1378936%22%20slang%3D%22en-US%22%3ERe%3A%20External%20user%20got%20permission%20but%20cant%20access%20page%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1378936%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F256200%22%20target%3D%22_blank%22%3E%40ShareP1610%3C%2FA%3E%26nbsp%3BI%20removed%20the%20guest%20user%20completly%2C%20waited%2024h%20and%20then%20added%20him%20back.%20Now%20it%20works%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

I've invited a external user to a site on my sharepoint but the user get the request access page when trying to access.

/sites/Test/testsite

 

When checking the permissions for the external user on the site it confirms that he has Read permission and should be able to access the site.

 

In Sharepoint admin center:

-Policies / sharing is set to "New and existing guests"

-Policies / Limit external sharing by domain and correct domain is added

-Sites / active sites, the parent site (/sites/Test) has "External sharing" set to "on"

 

In Azure Active Directory:

-The external user exists as a guest user. Source "External Azure AD".

 

I've tried to remove the user and add him again.

I've tried to approve access requested from the the "you need permission"- page. I get a "Request approved" but it's not working.

 

Not sure what setting I got wrong and why it's not working.

3 Replies
Highlighted

@ShareP1610 

Hello,

Does user has access to /sites/Test ?

 

 

Highlighted

@Alireza Rahimifarid 

When I check permissions the user got Read permission to /sites/test. But cant logg on to that either

Highlighted
Best Response confirmed by ShareP1610 (Occasional Contributor)
Solution

@ShareP1610 I removed the guest user completly, waited 24h and then added him back. Now it works